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Opis zadania  

 Ćwiczenie polega na zapoznaniu się z obsługą repozytoriów danych satelitarnych, samodzielnym 
wyszukaniu przykładowego zobrazowania satelitarnego z terenu Polski oraz zapoznaniu się 
z otwartym oprogramowaniem, które umożliwia prezentację i wykorzystanie pobranych danych 
satelitarnych oraz podstawowe przetworzenia na obrazach satelitarnych.  

Cel zadania 

Celem poniższej instrukcji jest przybliżenie odbiorcom sposobu, w jaki można pobrać dane satelitarne  
z wybranych repozytoriów danych satelitarnych oraz jak rozpocząć pracę na obrazach satelitarnych  
w specjalistycznym oprogramowaniu. Po szkoleniu odbiorca będzie wiedział jak i skąd pobierać obrazy 
satelitarne, na jakich programach pracować oraz nauczy się wstępnych przetworzeń zobrazowań.  

Wykaz danych przestrzennych GIS 

• Zobrazowanie satelitarne Sentinel-2: 
29.07.2019 (poziom L1C): 
S2B_MSIL1C_20190729T094039_N0208_R036_T34UEC_20190729T114538.SAFE 
29.07.2019 (poziom L2A): 
S2B_MSIL2A_20190729T094039_N0213_R036_T34UEC_20190729T123310.SAFE 

• Przycięte zobrazowania satelitarne Sentinel-2 z 29.07.2019 (poziom L2A): 
S2_20190729_T34UDC_10m_clip.tif  
S2_20190729_T34UEC_10m_clip.tif 

• Zobrazowanie Landsat 8 z 24.08.2019 (poziom L1TP):  
LC08_L1TP_188024_20190824_20190903_01_T1_2019-08-24 

• Granica obszaru zainteresowania (plik wektorowy w formacie Shapefile): Granica.shp 

Wykaz stron internetowych 

• Pobranie pliku instalacyjnego programu SNAP: https://step.esa.int/main/download/snap-
download/ 

• Pobranie pliku instalacyjnego programu QGIS 3.16, w zależności od wersji systemu 
operacyjnego Windows, należy pobrać wersję 32-bitową lub 64-bitową: 
wersja 64-bitowa: https://qgis.org/downloads/QGIS-OSGeo4W-3.16.13-1-Setup-
x86_64.exe 
wersja 32-bitowa: https://qgis.org/downloads/QGIS-OSGeo4W-3.16.13-1-Setup-x86.exe 
Niniejsze ćwiczenie zostało wykonane na wersji QGIS 3.16 Windows 64-Bit 

• Pobieranie zobrazowań satelitarnych Sentinel-2: https://scihub.copernicus.eu/dhus/#/home 
• System nazewnictwa plików danych satelitarnych Sentinel-2: 

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/naming-convention 
• System nazewnictwa plików danych satelitarnych Sentinel-1: 

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/naming-conventions 
• Opis plików z danymi satelitarnymi Sentinel-2: 

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/data-formats 
• Opis plików z danymi satelitarnymi Sentinel-1: 

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/data-formats/sar-formats 
• System obsługi klienta Sat4Envi: https://dane.sat4envi.imgw.pl/ 
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Wykaz zastosowanego oprogramowania 

• SNAP 8.0. 
• QGIS 3.16.  

Procedura instalacji oprogramowania 

Instalacja programu SNAP 8.0 
Pobranie pliku instalacyjnego programu SNAP: https://step.esa.int/main/download/snap-download/. 
W zależności od wersji systemu operacyjnego, należy pobrać odpowiedni plik. Niniejsze ćwiczenie 
zostało wykonane na wersji Windows 64-Bit z narzędziami Sentiel-1, -2, i -3. 
 

 

Uruchomienie pliku instalacyjnego programu SNAP ( ). 
W pierwszym oknie po uruchomieniu instalatora wybierz opcję Next. 

 
Zaakceptuj postanowienia licencyjne i wybierz opcję Next. 
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W oknie SNAP User Data użyj ustawień zalecanych, poprzez zaznaczenie opcji Delete only SNAP-
internal configuration data (recommended). W celu przejścia do dalszego etapu instalacji wybierz 
opcję Next. 

 
W kolejnym oknie instalatora wskaż docelową ścieżkę instalacji programu. Zaleca się pozostawienie 
domyślnej ścieżki instalacyjnej: C:\Program Files\snap. Po zdefiniowaniu ścieżki wybierz opcję Next. 

 
W oknie instalatora wybierz rozszerzenie Sentinel-2 Toolbox zawierające narzędzia do analizy 
zobrazowań satelitarnych Sentinel-2. Podczas instalacji programu na potrzeby wykonania niniejszej 
instrukcji zainstalowane zostały wszystkie dostępne rozszerzenia. Zaleca się zaznaczenie wszystkich 
rozszerzeń i wybranie opcji Next. 
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Kolejne okno instalatora pozwala zdecydować czy skrót do uruchomienia programu SNAP ma być 
dostępny z poziomu Menu Start systemu Windows. Zaleca się pozostawienie ustawień domyślnych 
i wybór opcji Next. 

 
Wskaż wersję języka programowania Python, który ma być wykorzystywany do wykonywania 
procesów lub tworzenia własnych narzędzi w języku Python. Zaleca się pozostawienie ustawień 
domyślnych i przejście do kolejnego okna za pomocą opcji Next. 

 
Wybierz opcje powiązujące rozszerzenie plików *.snap oraz *.dim z programem SNAP. W plikach 
z rozszerzeniem *.snap zapisywane są sesje programu SNAP, natomiast format *.dim jest domyślnym 
formatem zapisu danych w programie SNAP. Zaleca się wybór ustawień domyślnych i przejście do 
kolejnego okna przy użyciu opcji Next. 
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Utwórz skrót do programu na pulpicie komputera i dodaj ścieżkę programu do zmiennych 
środowiskowych systemu operacyjnego. Zakończ instalację przy użyciu opcji Finish.  

 
 
 
 
 
Instalacja wtyczki Sen2Cor do programu SNAP 

Po uruchomieniu oprogramowania SNAP zainstaluj wtyczkę wybierając menu Tools > Plugins. 
W panelu Available Plugins zaznacz wtyczkę Sentinel-2 SEN2COR280 Processor i kliknij Install.  
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W pierwszym oknie po uruchomieniu instalatora wybierz opcję Next. 

 

W kolejnym oknie zaznacz opcję Restart Now i kliknij Finish w celu zakończenia instalacji wtyczki 
i zrestartowania programu SNAP. 
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Instalacja programu QGIS 3.16 
W zależności od wersji systemu operacyjnego Windows, korzystając z poniższych linków, należy 
pobrać wersję 32-bitową lub 64-bitową: 
wersja 64-bitowa: https://qgis.org/downloads/QGIS-OSGeo4W-3.16.13-1-Setup-x86_64.exe 
wersja 32-bitowa: https://qgis.org/downloads/QGIS-OSGeo4W-3.16.13-1-Setup-x86.exe 
Niniejsze ćwiczenie zostało wykonane na wersji Windows 64-Bit. 

Uruchom samodzielnego instalatora programu QGIS 3.16. ( ) i wybierz opcję 
Dalej. 

 
Zaakceptuj umowę licencyjną wybierając Zgadzam się.  

 
Wskaż lokalizację, w której zostanie zainstalowany program QGIS 3.16. (zalecane jest pozostawienie 
ścieżki domyślnej) i wybierz Dalej.  

 
Wskaż opcjonalnie komponenty, które zostaną zainstalowane wraz z oprogramowaniem (QGIS 3.16., 
opcjonalnie można zaznaczyć materiały dodatkowe Data Set) oraz wybierz Zainstaluj.  

mailto:michal.pilecki@polsa.gov.pl
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Po zakończeniu instalacji oprogramowania wybierz Zakończ.  

 
 

Instalacja wtyczki Semi-Automatic Classification Plugin do programu QGIS 3.16 

Po uruchomieniu oprogramowania QGIS zainstaluj wtyczkę wybierając menu Wtyczki > Zarządzanie 
wtyczkami… W panelu wyszukiwania wpisz semi-… i wybierz wtyczkę Semi-Automatic Classification 
Plugin, kliknij Zainstaluj wtyczkę.  
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Opis ćwiczenia  

 
1. Pobieranie danych satelitarnych z Open Access Hub 

1.1. Uruchomienie przeglądarki Copernicus Open Access Hub i stworzenie konta użytkownika 

Uruchom przeglądarkę Open Hub https://scihub.copernicus.eu/dhus/#/home i stwórz nowe konto 
użytkownika podając odpowiednie dane w formularzu rejestracji. 

 

 
Po prawidłowym założeniu konta, zaloguj się. 

 

mailto:michal.pilecki@polsa.gov.pl
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W głównym oknie przeglądarki podstawowym podkładem mapy jest Open Street. Oprócz tego 
dostępne są jeszcze dwa podkłady mapowe (narzędzie Map Layers): 

• Terrain + Overlay - rzeźba terenu nałożona na warstwę Open street, 

 
• Sentinel-2 Cloudless + Overlay – ortofotomapa opracowana na podstawie zobrazowań 

Sentinel-2. 

 
W różnych przeglądarkach internetowych strona serwisu może wyglądać inaczej. Przedstawione tu 
przykłady zostały przygotowane z wykorzystaniem przeglądarki Chrome. 

1.2. Określenie obszaru zainteresowania (ang. area of interest, AOI) 

Narzędziem Navigation Mode zaznacz obszar zainteresowania AOI, dla którego mają być wyszukane 
zobrazowania Sentinel (zaznacz nieduży obszar np. w okolicach Warszawy).  

Rysowanie poligonu odbywa się poprzez zaznaczanie na mapie punktów lewym klawiszem myszy. 
Aby zamknąć poligon i zakończyć rysowanie należy kliknąć dwukrotnie. Poligon zostanie podświetlony 
na żółto. 

mailto:michal.pilecki@polsa.gov.pl
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1.3. Wyszukanie zobrazowania Sentinel-2 

W oknie wyszukiwania Insert search criteria jest możliwość podstawowego wyszukiwania obrazów 
po nazwie sceny lub rodzaju satelity. W zakładce Advanced Search można odnaleźć więcej opcji do 
wyszukiwania oraz kolejność w jakiej wyszukane zobrazowania mają być sortowane Order By, pod 
względem nazwy sceny Tile Id lub daty pozyskania oraz w jakiej kolejności (malejącej czy rosnącej) 
Sort By. Kolejna opcja dotyczy przedziałów czasowych w jakich poszukiwane są zobrazowania, można 
je wyszukać poprzez faktyczną datę pozyskania zdjęcia Sensing period lub przez datę udostępnienia 
zobrazowania Ingestion period. W zaawansowanej wyszukiwarce jest możliwość wybrania trzech 
satelitów (Sentinel-1, Sentinel-2, Sentinel-3). Należy pamiętać, że brak wyboru każdej z opcji będzie 
traktowany jako wybór ich wszystkich. Wszystkie trzy satelity mają dwa główne filtry wyszukiwania: 

• Satellite Platform - wybór sensora, obecnie każdy z satelitów posiada po dwa sensory -A  
i -B, 

• Product Type - wybór produktu jaki oferuje każdy z satelitów. 
Satelity posiadają także swoje szczegółowe parametry, m.in. rodzaj polaryzacji Polarisation (Sentinel-
1), tryb pozyskania zobrazowania Sensor Mode (Sentinel-1), rodzaj instrumentu Instrument (Sentinel-
3), poziom przetworzenia Product Level (Sentinel-3), względny numer orbity Relative Orbit Number 
(Sentinel-1, -2, -3), czy pokrycie zobrazowania chmurami Cloud Cover np. 0 do 9.4 (Sentinel-2).  
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Otwórz zakładkę Advanced Search i dla zaznaczonego obszaru zainteresowania wyszukaj 
zobrazowania  
Sentinel-2 w okresie od 01.07.2021 do 30.09.2021 (Sensing period) na poziomie przetworzenia L1C 
(Product Type), gdzie poziom pokrycia chmurami nie przekraczał 20% całego zobrazowania (Cloud 
Cover %). 

Dopuszczalny stopień zachmurzenia sceny należy wpisać w odpowiednie formule, gdzie procent 
zachmurzenia wyrażony jest w formie cyfry dziesiętnej w przedziale od 0 (0%) do 10 (100%), np. dla 
50% należy wpisać formułę [ 0 TO 5.0] 

 
Jeżeli nie został wyszukany żaden obraz, należy zmniejszyć ograniczenie zachmurzenia lub zupełnie 
zrezygnować z tego filtra wyszukiwania. 

1.4. Sprawdzenie metadanych zobrazowania Sentinel-2 

Z listy wyszukanych zobrazowań wybierz i zaznacz zobrazowanie o najmniejszym zachmurzeniu 
i poprzez kliknięcie w ikonę podglądu View Product Details sprawdź metadane wybranego 
zobrazowania: 

S2B_MSIL1C_20210909T095029_N0301_R079_T34UDC_20210909T104417 

 

 

 

pobieranie 
produktu 

dodanie produktu do 
koszyka 
 

informacja o produkcie 

przybliżenie do 
produktu 
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Zaznaczony obszar zainteresowania AOI obejmuje 6 scen (tzw. granule), które są przyciętymi obrazami 
satelitarnymi z jednej orbity o wielkości 100x100 km. Na poniższym rysunku pokazano, jakie sceny oraz 
ścieżki przelotu satelity znajdują się na terenie Polski.  
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Dzięki opcji Save Search jest możliwość zapisania wyników wyszukiwania. 

 

1.5. Pobranie zobrazowania Sentinel-2 

Pobierz wybrane zobrazowanie klikając w link do pobrania zobrazowania w oknie metadanych  

 
lub przycisk Download Product na liście wyszukanych scen.  
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Dla każdego użytkownika dozwolone jest jednoczesne pobieranie maksymalnie 2 scen. 

Najnowsze dane Sentinel przechowywane są na serwisie Copernicus Open Access Hub w trybie online 
(gotowe do natychmiastowego pobrania) co najmniej przez 1 miesiąc (praktycznie jest to kilka 
miesięcy). Po tym okresie dane zostają przesunięte do archiwum (tryb offline). Dane w trybie offline 
pobiera się z archiwum analogicznie jak dane online, z tym że są one możliwe do pobrania w ciągu 1 
godziny od zamówienia i dostępne do pobrania przez co najmniej 3 kolejne dni. Po pomyślnym 
przesłaniu zamówienia do Data Hub, zwracany jest komunikat potwierdzający, że produkt został 
zamówiony i zostaje automatycznie umieszczany w koszyku użytkownika Cart. Należy pamiętać, że 
zgłoszenie zamówienia danych z archiwum nie zapewnia automatycznego powiadomienia 
informującego użytkownika o gotowości produktu do pobrania. Użytkownik musi sam sprawdzić status 
swojego zamówienia w koszyku Cart. 

 
Pobrane zobrazowanie jest skompresowane do formatu .zip. Folder rozpakuj do: MD_3_1\Dane 

W folderze z pobranym zobrazowaniem Sentinel-2 znajduje się 5 podfolderów oraz 3 pliki: 
• AUX_DATA – folder z danymi pomocniczymi, 
• DATASTRIP – folder z danymi pomocniczymi oraz częścią metadanych, 
• GRANULE – folder zawierający obrazy pozyskane w poszczególnych kanałach spektralnych 

dla danej sceny Sentinel-2 (podgląd danych w formacie JPEG2000, GML, XML), 
• HTML – folder z metadanymi produktu w formacie HTML, 
• rep_info – folder ze schematem XLM produktu, 
• INSPIRE.xml – plik z metadanymi zgodny z założeniami dyrektywy INSPIRE, 
• manifest.safe – plik zawierający ogólne informacje o pobranym produkcie w formacie XML,  

dane 
dostępne 
online 

dane 
dostępne 
offline 
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• MTD_MSIL1C.xml – plik XML zawierający informacje o metadanych i zasięgu całej sceny. 

 
Więcej informacji o pobranych plikach można znaleźć pod adresem:  
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/data-formats 

Poniżej przedstawiono schemat nazewnictwa pliku z obrazem satelitarnym Sentinel-2. 

 
Szczegółowe objaśnienia nazewnictwa zostały opisane na stronie: 
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/naming-convention 
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2. Pobieranie danych satelitarnych z platformy Sat4Envi 

W Polsce stworzony został, jako krajowy punkt dostępowy do danych satelitarnych, system Sat4Envi. 
Podobnie jak w przypadku Open Access Hub pozwala na pobieranie zobrazowań satelitarnych (misje 
Sentinel-1, -2, -3 i dodatkowo -5), a także danych meteorologicznych (dane satelitarne z satelitów 
Meteosat oraz NOAA i MetOp). Ponadto w portalu można przeglądać szereg tzw. produktów, czyli 
opracowanych zdjęć satelitarnych. Serwis danych satelitarnych Sat4Envi dostępny jest pod adresem:  
https://dane.sat4envi.imgw.pl/ 

Portal Sat4Envi nie wymaga rejestracji, ale dla zarejestrowanych użytkowników przewidziano dostęp 
do większej liczby produktów oraz dodatkowej funkcjonalności, tj.: 

• pobieranie danych, 
• zarządzanie ulubionymi produktami, 
• dostęp do dodatkowych warstw WMS. 

2.1. Rejestracja i logowanie do portalu klienta Sat4Envi 

Aby mieć dostęp do pełnej funkcjonalności portalu klienta Sat4Envi należy stworzyć nowe konto 
użytkownika podając odpowiednie dane w formularzu rejestracji. 

 
 

2.2. Dostęp do produktów portalu klienta Sat4Envi 

Po zalogowaniu się do serwisu w zakładce ZDJĘCIA SATELITARNE dostępny jest podgląd tzw. 
produktów, czyli opracowanych zdjęć satelitarnych pogrupowanych tematycznie w 5 kategorii: 

• POWIERZCHNIA: obrazy SAR (Sentinel-1) w trybie skanowania IW (Interferometric Wide 
Swath) i EW (Extra wide) typu GRD (Ground Range Detected) oraz SLC (Single Look Complex), 
dane Sentinel-2 w postaci kompozycji barwnej RGB (barwy rzeczywiste). 

• POWIETRZE: pył w atmosferze, ozon, zawartość dwutlenku azotu. 

• ATMOSFERA/METEOROLOGIA: zachmurzenie, chmury konwekcyjne oraz dane Meteosat,  
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• DESZCZE i BURZE: wyładowania atmosferyczne, intensywność opadu, suma opadów, chmury 
konwekcyjne wysoko wypiętrzone, wilgotność gleby. 

• INNE: Airmass, detekcja chmur lodowych i śniegu, kompozycja Mikrofizyka. 

 
W zakładce tej jest również możliwość wyszukania danej lokalizacji Wpisz szukaną miejscowość, 
wyświetlenia granic administracyjnych na kilku poziomach Warstwy: 

• województwa, 

• powiaty, 

• gminy, 

• jednostki ewidencyjne, 

• obręby ewidencyjne 

oraz skonfigurowania lub dodania nowych warstw WMS. 

Po wybraniu danego produktu np. kompozycji barwnej z obrazów Sentinel 2 L1C (kategoria 
POWIERZCHNIA), w dolnej części przeglądarki pojawia się oś czasu, na której można wybrać 
określony dzień i godzinę (np. 12.05.2021 11:50) pozyskania danych satelitarnych. Dane dla 
konkretnych produktów są dostępne tylko dla dat oznaczonych żółtym kółkiem.  

Przykład kompozycji barwnej RGB w barwach rzeczywistych z danych Sentinel-2: 
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Każdy produkt posiada krótka notatkę informacyjną, którą można wyświetlić przez klikniecie  
w ikonę  ( lewy górny róg mapy), a część z nich posiada również legendę (z prawej strony mapy), 
której opis można włączyć lub wyłączyć. Dostęp do aktualnych i archiwalnych danych satelitarnych 
możliwy jest przez linię czasu (na dole mapy). Najnowsze dane satelitarne można oglądać w trybie NA 
ŻYWO, gdy tylko zostaną przesłane z satelity do serwisu (w zależności od rodzaju produktu może być 
to co kilkanaście minut – dane meteorologiczne z satelitów geostacjonarnych lub nawet co kilka dni – 
dane powierzchniowe z satelitów okołobiegunowych). Dostęp do danych archiwalnych możliwy jest 
przez wybór konkretnej daty za pomocą przycisku kalendarza i godziny lub paska czasu, na którym 
wyświetlane są wszystkie dostępne sceny w danym dniu w ujęciu 24-, 12-, 6-, 3- lub 1-godzinnym  
( ). Wyniki wyświetlania produktów można zapisać jako obraz PNG (górny prawy róg mapy 
w panelu profilu użytkownika). 

Przeanalizuj inne dostępne produkty satelitarne, np.: 

• Pył w atmosferze, kategoria POWIETRZE (np. 01.02.2021 00:00):  

 
• Chmury konwekcyjne, kategoria ATMOSFERA/METEOROLOGIA (np. 01.02.2021 08:00, 

12:00, 16:00, 20:00): 
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• Chmury konwekcyjne wysoko wypiętrzone, kategoria DESZCZE i BURZE (np. analiza 

nawałnicy w Borach Tucholskich 11.08.2017): 

 
• Airmass, kategoria INNE (np. analiza nawałnicy w Borach Tucholskich 11.08.2017): 
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Dodaj dowolną warstwę WMS (Konfiguruj WMS), np.  Bank Danych o Lasach: 
https://mapserver.bdl.lasy.gov.pl/ArcGIS/services/WMS_BDL/mapserver/WMSServer: 

Każdą warstwę WMS można włączyć lub wyłączyć z wyświetlania na mapie w konfiguratorze WMS 
zaznaczając odpowiednią opcję Pokaż w panelu. 

 
 

Dodawanie produktów do listy Ulubione: 

Na liście produktów satelitarnych Sat4Envi jest również możliwość dodawania wybranych produktów 
do listy Ulubione ( ), dzięki czemu można komponować własne ustawienia przeglądarki produktów 
zapisywanych na naszym profilu i dostępnych przy następnym logowaniu do portalu Sat4envi. 
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2.3. Wyszukiwanie danych satelitarnych i pobieranie danych Sentinel-2 poziomu Level-2A 

W zakładce SZUKAJ DANYCH znajduje się wyszukiwarka źródłowych danych satelitarnych Sentinel 
(-1, -2, -3 i -5) oraz danych MSG i satelitów polarnych.  

W celu wyszukania zobrazowania Sentinel-2 zaznacz na mapie obszar wyszukiwania (np. okolice 
Warszawy), a na panelu wyszukiwania: rodzaj satelity SENTINEL-2, produkt Charakterystyka 
powierzchni o wysokiej rozdzielczości, na poziomie przetworzenia Level-2A, maksymalne pokrycie 
chmurami 20% Pokrywa chmur, przedział czasu rejestracji w filtrze Detekcja od np. od 01.07.2021 do 
Detekcja do np. 30.09.2021. 

 
Po naciśnięciu przycisku Szukaj zostaje wyświetlona lista wyszukanych zobrazowań spełniających 
dane kryteria wyszukiwania. Korzystając z listy wyników można wyświetlić metadane wybranej sceny  
lub pobrać dane źródłowe. 
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2.4. Pobranie zobrazowania Sentinel-1 

Wyszukaj zobrazowanie Sentinel-1 zgodnie z podanymi kryteriami: 

• produkt Sentinel 1 GRDH,  
• tryb sensora IW,  
• przedział czasu rejestracji np. od 01.07.2021 do 30.09.2021. 

i pobierz wybrane zobrazowanie klikając w ikonę POBIERZ przy wybranej scenie zobrazowania 
Sentinel-1 lub w oknie metadanych: 

S1A_IW_GRDH_1SDV_20210924T161934_20210924T161959_039826_04B60A_0607 

 
Obrazy pobierane są w oryginalnym formacie SAFE i spakowane.  

Zapisz pobraną scenę i rozpakuj do: MD_3_1\Dane 
 
W folderze z pobranym zobrazowaniem Sentinel-1 znajduje się 4 podfoldery oraz 2 pliki: 

• annotation – folder z metadanymi opisującymi właściwości i cechy danych pomiarowych oraz 
sposób ich wygenerowania, 

• measurement – folder z danymi radarowymi Sentinel-1, 
• preview – folder zawierający podgląd danych radarowych w niskiej jakości, 
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• support – folder zawierający dane pomocnicze do sprawdzania poprawności i wykorzystania 
danych radarowych, 

• manifest.safe – plik zawierający ogólne informacje o pobranym produkcie w formacie XML,  
• *-report-.pdf  – plik PDF zawierający wyniki kontroli jakości danych. 

 
Więcej informacji o pobranych plikach można znaleźć pod adresem:  
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/data-formats/sar-formats 

Poniżej przedstawiono schemat nazewnictwa pliku z obrazem satelitarnym Sentinel-1. 

 
Szczegółowe objaśnienia nazewnictwa zostały opisane na stronie: 
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/naming-conventions 

 

 

 

  

S1B_IW_GRDH_1SDV_20200210T045115_20200210T045144_020202_0263F2_0D45.SAFE 

Identyfikator misji: 
„S1A”, „S1B” 

Tryb/Wiązka: 
„S1/S2/S3/S4/S5/S6” 

„IW/EW/WV” 

Typ produktu: 
„SLC:, „GRD”, „OCN” 

Rozdzielczość: 
„F” - pełna 

„H” - wysoka 
„M” - średnia 

Polaryzacja: 
„SH” - Single HH 
„SV” - Single VV 

“DH” - Dual HH HV 
„DV” - Dual VV+VH 

Numer orbity 

Identyfikator misji  

Identyfikator 
produktu  

Format produktu  
Czas rozpoczęcia 

pozyskania  danych 
Czas zakończenia 

pozyskania danych 

Klasa produktu 
„S” – Standard 

„A” - Annotation 

Pozom przetworzenia: 
„1”, „2”  
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https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/data-formats/sar-formats
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/naming-conventions


                                                                                               

28 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

3. Wstęp do pracy z danymi satelitarnymi w programie ESA SNAP 

3.1. Uruchomienie programu SNAP 

Uruchom program SNAP z menu Start systemu lub przez ikonę na pulpicie . Po pierwszym 
otwarciu pojawi się interfejs programu: 

A. Pasek menu, 
B. Pasek narzędzi, 
C. Okno zawartości, 
D. Widok główny, 
E. Podgląd (narzędzia: Navigation, Colour Manipulation, World View, World Map, 

Uncertainty Visualisation) 

 
Widok programu SNAP może być inny w zależności od tego jakie pakiety narzędzi, tzw. toolboxy, 
zostały zainstalowane. 

3.2. Dodanie danych satelitarnych Sentinel-2 do programu SNAP 

Otwórz pobraną scenę Sentinel-2 narzędziem Open Product lub menu File > Open Product. Po 
wyszukaniu folderu z danymi:  
MD_3_1\Dane\S2B_MSIL2A_20190729T094039_N0213_R036_T34UEC_20190729T123310.SAFE 
załaduj ostatni plik o nazwie MTD_MSIL2A.xml. 

 
Po załadowaniu pliku, w oknie zawartości pojawi się obraz satelitarny z satelity Sentinel-2B. Dodany 
obraz posiada katalog, który można rozwinąć klikając na biały kwadrat z plusem znajdujący się po lewej 
stronie nazwy pliku. W katalogu sceny Sentinel-2 znajdują się 4 główne foldery z informacją 

D 

C 

E 

B A 
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o metadanych (Metadata), folder z plikami wektorowymi (Vector data), folder z poszczególnymi 
kanałami zdjęcia (Bands) oraz folder z maskami (Masks). Zobrazowania Sentinel-2, posiadają 
dodatkowo w pobranych plikach informację o rodzajach chmur, pokrywie śnieżnej lub lodowej. Maski 
nakłada się na obraz, aby usunąć inne informacje z obrazu niż rzeczywiste pokrycie terenu. W folderze 
Bands można znaleźć informację ile kanałów posiada dany obraz i jaka jest ich centralna długość fali. 
Dodatkowe informacje o każdym kanale można wyświetlić we właściwościach obrazu klikając prawym 
przyciskiem myszy (PPM) i wybierając Properites. 

 

3.3. Wizualizacja danych satelitarnych Sentinel-2 w programie SNAP 

W celu wyświetlenia obrazu Sentinel-2 wybierz pojedynczy kanał zobrazowania z listy. Jest to możliwe 
po dwukrotnym naciśnięciu lewego przycisku myszy (LPM).  

 
W oknie podglądu jest możliwość wizualizacji dodatkowych informacji o obrazie jak Uncertainty 
information lub Quicklooks (o ile są dostępne) oraz dokładnej lokalizacji pobranego obrazu w zakładce 
World View lub World Map.  
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Jeżeli w oknie podglądu nie jest widoczna jakaś zakładka, można ją włączyć z menu View > Tool 
Windows 

 

 
Zakładka Navigation służy do zmiany położenia i powiększenia widoku okna głównego.  

Odpowiednie narzędzia do nawigacji po obrazie dostępne są również w pasku narzędzi. Powiększanie 
i pomniejszanie widoku obrazu możliwe jest również poprzez manipulację kółkiem myszki, 
a przesuwanie – lewym klawiszem myszki przy wciśniętym klawiszu spacji. 

mailto:michal.pilecki@polsa.gov.pl


                                                                                               

31 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

  
W celu łatwiejszej nawigacji przy jednoczesnym przeglądaniu większej ilości obrazów należy włączyć 
narzędzie Synchronise View i Synchronise Cursor w zakładce Navigation oraz przearanżować 
odpowiednio widok okna głównego narzędziami dostępnymi z paska narzędzi (Tile Horizontally, Tile 
Vertically, Tile Evenly, Tile Single). 

 
W najnowszej wersji program SNAP automatycznie wzmacnia kontrast obrazu podczas jego 
otwierania, ale istnieje też możliwość manipulacji histogramem (zwężanie, rozszerzanie) oraz jasnością 
i kontrastem obrazu. Celem takiego działania jest poprawa interpretacji obrazu. 

W oknie podglądu w zakładce Color Manipulation użyj narzędzia Auto-adjust to 100% of all pixels 
w celu wyświetlenia wszystkich pikseli.  

powiększanie 

pomniejszanie 

rzeczywisty rozmiar piksela  
(piksel obrazu = piksel widoku) 

widok całej sceny 

synchronizacja widoku 
i kursora przy otwartych 
kilku obrazach 
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Następnie ręcznie dostosuj histogram zwiększając i zmniejszając zakres skali szarości oraz jasność 
i kontrast obrazu, tak aby poprawić widoczność szczegółów. 

 
Na koniec wróć do automatycznych ustawień histogramu Reset to defaults lub dopasuj histogram do 
95% Auto-adjust to 95% of all pixels. 
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W oknie zawartości w zakładce Pixel Info można odczytać wartości jasności poszczególnych pikseli 
obrazu wskazanych przez kursor myszki.  

Przy włączonych kilku obrazach oraz włączonej synchronizacji widoku i kursora można odczytać 
jednocześnie wartości pikseli kilku obrazów (kanałów Sentinel-2). 
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3.4. Tworzenie kompozycji barwnych w programie SNAP 

Kompozycje barwne tworzy się w celu lepszego podkreślenia, zwizualizowania niektórych cech 
krajobrazu, co ułatwia interpretację zdjęcia. Każdy z kanałów przepuszcza się przez odpowiedni filtr R-
red, G-green, B-blue co pozwala na uzyskanie kolorowego obrazu. 

Najbardziej popularną kompozycją barwną jest kompozycja RGB w barwach naturalnych. Tworzymy 
ją poprzez przypisanie kanałów o takich samych barwach jak ich widmo światła. Dla składowej R – 
przypisuje się zakres widma zawierający światło czerwone, dla składowej G – światło zielone, a dla 
składowej B – światło niebieskie. W przypadku satelity Sentinel-2 kompozycja RGB w barwach 
naturalnych to kanały 4, 3 i 2 (R – kanał 4, G – kanał 3, B – kanał 2) 

W celu otwarcia obrazu Sentinel-2 w kompozycji barwnej kliknij prawym klawiszem myszy (PPM) na 
nazwę katalogu obrazu i wybierz z rozwijalnej listy Open RGB Image Window lub z menu Window > 
Open RGB Image Window. 

 
W celu pozyskania obrazu w barwach naturalnych do filtra czerwonego (R) przypisz kanał B4, do filtra 
zielonego (G) przypisz kanał B3, zaś do filtra niebieskiego (B) – kanał B2 i zatwierdź przyciskiem OK.  
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Innym przykładem kompozycji barwnych jest kompozycja w barwach fałszywych CIR, w przypadku 
Sentinela-2 jest to kompozycja składająca się z kanałów 8, 4 i 3, czyli odpowiednio bliskiej 
podczerwieni, czerwieni oraz zieleni. Do składowej R przypisuje się zakres widma bliskiej podczerwieni 
(B8), składowej G – zakres czerwony (B4), zaś składowej B – zakres zielony (B3).  

Kanały do kompozycji CIR wybierz ręcznie, ponownie narzędziem Open RGB Window lub poprzez 
wybór opcji Sentinel 2 MSI False-Color Infrared z pola Profile.  

 
Kompozycja w barwach fałszywych CIR jest często wykorzystywanym w teledetekcji rodzajem 
podstawowej wizualizacji zobrazowań satelitarnych. Kompozycja CIR ułatwia interpretację poprzez 
wyodrębnienie specyficznych cech obrazu. Roślinność zielona przedstawiona jest barwą czerwoną. 
Kompozycja ta pozwala również odróżnić drzewa liściaste (barwa jasnoczerwona) od drzew iglastych 
(barwa ciemnoczerwona). Łąki przyjmują odcienie różu, natomiast odkryta gleba na polach uprawnych 
to odcienie koloru seledynowego. Bliska podczerwień jest mocno pochłaniania przez wodę, dlatego na 
obrazach z jej wykorzystaniem ma ona kolor ciemnego granatu lub nawet czerni, przez co dobrze 
wyróżnia się na tle innych form porycia terenu. Z kolei zabudowa zobrazowana jest w odcieniach  
błękitu i bieli, a drogi w odcieniach szarości. 
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Następnie wykorzystaj wbudowany w narzędzie Open RGB Window profil Sentinel 2 MSI 
Atmospheric Penetration do stworzenia kolejnej kompozycji w barwach fałszywych. 

Kompozycja w barwach fałszywych Atmospheric Penetration wykorzystuje kanały podczerwieni NIR 
i krótkiej podczerwieni SWIR1 i SWIR2, które lepiej przenikają przez atmosferę, dym czy mgłę 
redukując wpływ atmosfery na zdjęcie. Woda ma niskie wartości w zakresie NIR i SWIR, podczas gdy 
lód i śnieg ma wartości wysokie, dzięki czemu na tej kompozycji granice tych obiektów są łatwo 
interpretowane. Roślinność w tej kombinacji kanałów spektralnych jest niebieska, ukazując szczegóły 
związane z jej kondycją. Zdrowa roślinność jest pokazana na jasnoniebiesko, podczas gdy roślinność 
rzadka lub/i sucha, w złej kondycji obrazowana jest na niebiesko. Z kolei tereny zurbanizowane  
odwzorowane są w bieli, szarość lub fiolecie, a goła gleba w odcieniach brązu i żółci. Woda w tej 
kompozycji pojawia się w bardzo ciemnych odcieniach koloru niebieskiego lub czerni, dzięki czemu linie 
brzegowe są dobrze zaznaczone.  

 
Podobnie jak w przypadku wizualizacji obrazów z pojedynczymi kanałami spektralnymi, kontrast 
i jasność kompozycji barwnych można również dostosować przez manipulację histogramem 
poszczególnych barw w zakładce Color Manipulation w oknie podglądu. 
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Stworzone kompozycje barwne można zapisać w postaci obrazka z wybranego widoku View region 
(PNG, TIFF, JPG, BMP) lub całej sceny Full Scene wraz z geolokalizacją (GeoTIFF) w pełnej 
rozdzielczości Full resolution, rozdzielczości widoku View resolution lub rozdzielczości ustalonej przez 
użytkownika User resolution. Eksport kompozycji barwnych wykonuje się za pomocą narzędzia Export 
View as Image dostępnego z menu kontekstowego pod PPM. 

 

3.5. Praca z danymi wektorowymi w programie SNAP 

W oprogramowaniu możliwa jest również praca na danych wektorowych. Są one głównie przydatne 
do określania obszaru zainteresowania AOI np. podczas klasyfikacji pikselowej.  

Aby stworzyć nowy wektor wybierz menu Vector > New Vector Data Container.  

 
Po stworzeniu nowej warstwy wektorowej pojawi się ona w oknie zawartości w plikach obrazu Vector 
Data i zostanie odblokowana możliwość rysowania poligonów narzędziem Drawing Tools.  

Narysuj kilka poligonów.  

Jeżeli wektorów jest więcej należy zwrócić szczególną uwagę do którego wektora przypisany jest dany 
poligon.  
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Eksport warstwy wektorowej możliwy jest do formatu shapefile (PPM na wybranej warstwie > 
Geometry as Shape file lub menu Vector > Export > Geometry as Shape file). 

Warstwy wektorowe można importować do programu SNAP z formatów: 

 

3.6. Mozaikowanie obrazów Sentinel-2 i przycinanie do wektora w programie SNAP 

Dane satelitarne Sentinel-2 podzielone są na sceny (tzw. granule, tile), które są przyciętymi obrazami 
satelitarnymi z jednej orbity o wielkości 100x100 km z dodatkowym pasem wspólnego pokrycia 
o szerokości 10 km. Gdy wybrany obszar zainteresowania znajduje się na granicy dwóch scen, można 
te sceny połączyć ze sobą (zmozaikować) i przyciąć do wybranego obszaru.  

Ponieważ proces mozaikowania całych scen Sentinel-2 jest czasochłonny, a powstała mozaika bardzo 
dużym plikiem, na potrzeby ćwiczenia przygotowano dwa mniejsze fragmenty sąsiednich scen 
Sentinel-2 w formacie wielokanałowego rastra TIFF (składające się z kanałów Sentinel-2 B2, B3, B4 
i B8), które zostaną poddane procesowi mozaikowania. Fragmenty scen Sentinel-2 został zapisane do 
rastrów, gdzie poszczególne kanały spektralne zostały zapisane w następującej kolejności: 
B2 (kanał niebiski) = band_1 
B3 (kanał zielony) = band_2 
B4 (kanał czerwony) = band_3 
B8 (kanał podczerwieni) = band_4 

Usuń wszystkie wczytane dane z programu menu File > Close All Products i dodaj do projektu dwa 
wielokanałowe rastry (File > Open Product) z folderu: z folderu MD_3_1\Dane\ 
S2_20190729_T34UDC_10m_clip.tif  
S2_20190729_T34UEC_10m_clip.tif  
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Następnie dla nowo dodanych produktów stwórz kompozycje w barwach naturalnych RGB (Open 
RGB Image Window) 

 
W celu zmozaikowania obu scen Sentinel-2 wybierz z menu Raster > Geometric > Mosaicing 

Narzędzie Mosaicing wymaga, aby wszystkie kanały łączonych rastrów były tej samej rozdzielczości 
przestrzennej. Jeżeli rastry wybrane do mozaikowania nie są tej samej rozdzielczości należy je 
wcześniej przetworzyć do tej samej rozdzielczości przestrzennej narzędziem Resampling (menu Raster 
> Geometric > Resampling) lub do mozaikowania użyć narzędzia Multi-size mosaic (menu Raster > 
Geometric > Multi-size mosaic) 

  
W oknie Mosaicing w zakładce I/O Parameters dodaj oba rastry klikając w ikonę  i wybierając 
odpowiednie pliki TIFF z fragmentami obu scen Sentinel-2. Wskaż miejsce zapisu mozaiki 
MD_3_1\Wyniki, jej nazwę np. S2_ 20190729_mosaic oraz rozszerzenie np. GeoTIFF i zaznacz opcję 
Open in SNAP. 
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W zakładce Map Projection Definition wybierz docelowy układ współrzędnych mozaiki UTM/WGS 84 
(Automatic). W oknie z widokiem mapy Mosaic Bound zaznacz opcję Display source products, 
wyświetl granice załadowanych scen klikając w ikonę Zoom to selected product i dostosuj granice 
wynikowej mozaiki oraz ustal rozmiar piksela wynikowej mozaiki Pixel size X, Pixel Size Y na 10 m. 

 
W zakładce Variables & Conditions wybierz które kanały scen Sentinel-2 mają zostać zmozaikowane 
klikając w ikonę Choose the bands to process. W celu stworzenia kompozycji w barwach naturalnych 
w oknie Band chooser zaznacz wszystkie kanały Select all. Uruchom proces mozaikowania klikając 
w przycisk Run. 
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Po zakończeniu procesu mozaikowania w oknie zawartości Product Explorer pojawi się obliczona 
mozaika. Wyświetl ją w kompozycji barw naturalnych za pomocą narzędzia Open RGB Image 
Window. 

Wynikowa mozaika w kompozycji barw naturalnych. 

 
W celu przycięcia mozaiki do danego obszaru zainteresowania w pierwszej kolejności należy wczytać 
plik wektorowy z granicą obszaru zainteresowania Granica.shp do programu SNAP za pomocą 
narzędzia File > Import > Vector Data > ESRI Shapefile. Następnie uruchom narzędzie do przycinania 
rastrów z menu Raster > Masks > Land/Sea Mask 
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W oknie Land/Sea Mask w zakładce I/O Parameters jako Source Product wybierz utworzoną mozaikę. 
Wskaż miejsce zapisu mozaiki MD_3_1\Wyniki, jej nazwę np. S2_ 20190729_mosaic_msk oraz 
rozszerzenie np. GeoTIFF i zaznacz opcję Open in SNAP 

 
W zakładce Processing Parameters zaznacz do przycięcia wszystkie kanały Source Band, odznacz 
opcję Use SRTM3sec, zaznacz opcję Use Vector as Mask i z rozwijalnej listy wybierz warstwę Granica. 
Pozostałe parametry pozostaw bez zmian i kliknij Run. 
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Mozaika przycięta do granicy obszaru zainteresowania zostanie dodana do programu SNAP jako 
kolejny produkt. Wyświetl ją w kompozycji barw rzeczywistych i fałszywych CIR. 

Wynikowa mozaika przycięta do granicy obszaru zainteresowania w barwach naturalnych oraz 
fałszywych CIR (z użyciem kanału podczerwieni): 
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4. Wstęp do pracy z danymi satelitarnymi w programie QGIS 

Program QGIS jest darmowym oprogramowaniem GIS przeznaczonym do pracy na danych rastrowych 
oraz wektorowych. QGIS daje możliwość m.in. gromadzenia, przetwarzania (tworzenia, selekcji, 
identyfikowania, edytowania, przeglądania, zarządzania), wyświetlania, analizowania, interpretowania 
i udostępniania danych przestrzennych, oraz publikowanie ich w Internecie. 

 

4.1. Uruchomienie programu QGIS Desktop 3.16. 

W Start systemu operacyjnego Windows wyszukaj i wybierz QGIS Desktop 3.16. 

Interfejs programu QGIS 3.16. składa się z następujących głównych elementów: 
A. Pole pracy. 
B. Pole przeglądarki. 
C. Pole warstw.  
D. Pola zakładek i narzędzi.  
E. Pole informacyjne. 

 
Jednak trzeba mieć na uwadze, że wygląd poszczególnych elementów może się różnić w zależności 
od wersji QGIS i ustawień użytkownika. 

4.2. Dostosowanie układu współrzędnych projektu do układu odpowiadającego pobranym 
zobrazowaniom satelitarnym Sentinel-2. 

W celu dostosowania układu współrzędnych do układu danych Sentinel-2 wybierz menu Projekt > 
Właściwości i zakładkę Układ współrzędnych lub w polu informacyjnym w prawym dolnym rogu 
ekranu kliknij ikonę Bieżący układ współrzędnych.  
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Zobrazowania satelitarne Sentinel-2 posiadają układ współrzędnych UTM (Universal Transverse 
Mercator), strefa 33N lub 34N. 

W oknie Właściwości projektu wybierz układ współrzędnych UTM (Universal Transverse Mercator), 
strefa 34N. W celu wyszukania danego układu w polu wyszukiwania Filtr wpisz odpowiedni kod EPSG: 
32634 i wybierz wyszukany układ WGS84/ UTM zone 34N. Wybór układu zatwierdź przyciskiem 
Zastosuj oraz OK. Po wykonaniu powyższych czynności w prawym dolnym rogu powinien być 
widoczny kod układu EPSG ( ). 

 

4.3. Zapisanie projektu 

Z menu Projekt wybierz Zapisz. Zapisz projekt pod nazwą QGIS_Podstawy w lokalizacji: 
MD_3_1\Wyniki 

4.4. Wczytanie danych Sentinel-2 do projektu. 

W celu dodania danych do projektu przejdź do zakładki Przeglądarka (zlokalizowana jest po lewej 
stronie interfejsu programu QGIS 3.16.) i ustal lokalizację folderu MD_3_1\Dane. Z folderu 
MD_3_1\Dane\ 
S2B_MSIL2A_20190729T094039_N0213_R036_T34UEC_20190729T123310.SAFE\GRANULE\L2
A_T34UEC_A012503_20190729T094242\IMG_DATA\R10m\ wybierz pliki JP2 z kanałami Sentinel-
2 L2A z zakresu widzialnego (2, 3, 4) i podczerwieni (8) o GSD 10 m: 

• T34UEC_20190729T094039_B02_10m.jp2 
• T34UEC_20190729T094039_B03_10m.jp2 
• T34UEC_20190729T094039_B04_10m.jp2 
• T34UEC_20190729T094039_B08_10m.jp2 

i przeciągnij je do centralnej części interfejsu programu QGIS 3.16.  

mailto:michal.pilecki@polsa.gov.pl


                                                                                               

46 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

 
Innym sposobem dodawanie danych rastrowych jest użycie narzędzia Zarządzanie źródłami danych 
w menu Warstwa > Dodaj warstwę > Dodaj warstwę rastrową. 

W polu pracy zostaną wyświetlone dodane zobrazowania, a w zakładce Warstwy pojawią się 
odpowiednie pliki. 

 

4.5.  Wzmocnienie kontrastu wyświetlania zobrazowania – rozciągniecie histogramu. 

Wczytując dane rastrowe do programu zostają one wyświetlone w domyślnych ustawieniach, czyli 
wyświetlane są wszystkie wartości jasności od minimum do maksimum. Często przy tych ustawieniach 
zobrazowania Sentinel-2 są nieczytelne. Dlatego konieczna jest zmiana ustawień wyświetlania obrazu, 
poprzez wzmocnienie kontrastu obrazu. 
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Prostym sposobem wzmocnienia kontrastu wybranego rastra jest użycie narzędzia Wzmocnij kontrast 
do zasięgu widoku lub Wzmocnij kontrast do pełnego zakresu danych z paska narzędzi Raster. Jeżeli 
pasek narzędzie nie jest widoczny włącz go przez wybranie menu Widok > Paski narzędzi > Raster 

 
Aby mieć pełniejszą kontrolę nad sposobem wyświetlania obrazu w zakładce Warstwy wybierz obraz 
T34UEC_20190729T094039_B02_10m i pod prawym przyciskiem myszy (PPM) z menu 
kontekstowego wybierz Właściwości. W oknie Właściwości warstwy w zakładce Styl ustal parametr 
Wzmocnienie kontrastu na rozciągnij i przytnij do min./max. Następnie rozwiń pasek Ustawienia 
wartości minimalnej i maksymalnej i wybierz opcję średnia +/- odchylenie standardowe x i zatwierdź 
przyciskiem OK. 

 
Analogicznie zmień sposób wyświetlania pozostałych kanałów spektralnych poprzez wzmocnienie 
kontrastu. 
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4.6. Zarządzanie wyświetlaniem danych rastrowych. 

W zakładce Warstwy zmień kolejność wyświetlania warstw (przeciągnij, upuść) i pozostaw 
widoczny tylko kanał podczerwieni (T34UEC_20190729T094039_B08_10m) 

 

4.7. Tworzenie kompozycji barwnych. 

W celu stworzenia kompozycji barwnej w barwach naturalnych obrazu Sentinel-2 utwórz nowy raster 
tymczasowy zawierający kanały 4, 3, 2 – menu Raster > Różne > Twórz wirtualny raster.  
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W oknie Twórz wirtualny raster kliknij  na zakładkę Imput layers i w oknie Zaznaczanie wielokrotne 
wybierz Zaznacz wszystko i zatwierdź. Zapisz wirtualny raster w pliku tymczasowym i uruchom proces 
Uruchom.  

 
W zakładce Warstwy utworzony zostaje Raster wirtualny. Jest on zapisany tymczasowo. Aby zapisać 
wirtualny raster wielokanałowy do pliku kliknij PPM na Wirtualny raster i wybierz Eksportuj > Zapisz 
jako… W oknie Zapisz warstwę rastrową jako podaj Nazwa pliku: S2_20190729_T34UEC_10m.tif 
i lokalizację zapisywanego obrazu: MD_3_1\Wyniki.  

 

W celu ustawienia odpowiedniej kompozycji barwnej w zakładce Warstwy kliknij dwukrotnie na 
stworzony raster wielokanałowy (S2_20190729_T34UEC_10m) i uruchom okno Właściwości. 
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W oknie Właściwości warstwy wskaż zakładkę Styl. W polu Renderowanie kanałów, by uzyskać 
obraz w barwach naturalnych ustaw rozwijane pola kanałów na kanał czerwony – Kanał 3, kanał 
zielony – Kanał 2, kanał niebieski – kanał 1. Dla kompozycji CIR kolejność kanałów nowo stworzonego 
wielokanałowego rastra to (4,3,2). Kompozycja CIR (Color Infrared) w kolorze czerwonym lub 
purpurowym przedstawia tereny zielone, natomiast w niebieskim tereny pozbawione wegetacji.  

 
Uwaga: Numery kanałów wybierane na tym etapie mogą nie zgadzać się z oryginalnymi numerami 
kanałów obrazu Sentinel-2. Na etapie tworzenia rastra wirtualnego brane pod uwagę są tylko  
wybrane kanały i w nowym rastrze zapisane są z nową kolejnością – taką jaka została ustawiona przy 
tworzeniu rastra. Jeśli np. w Sentinel-2 po kolei wybrano kanał 2,3,4,8 to nowa numeracja przypisze 
2->1, 3->2, 4->3 i 8->4.  

Wynikowe kompozycje w barwach naturalnych oraz fałszywych CIR (z użyciem kanału podczerwieni): 
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4.8. Praca z danymi wektorowymi w programie QGIS. 

Program QGIS ma rozbudowaną funkcjonalność tworzenia i edytowania danych wektorowych. W tym 
ćwiczeniu poznamy jedynie podstawy pracy z danymi wektorowymi. 

Stwórz nową warstwę wektorową wykorzystując narzędzie z menu Warstwa > Twórz warstwę > 
Nowa warstwa shapefile.  Nadaj nazwę pikowi wektorowemu np. Poligons.shp i wskaż miejsce zapisu 
MD_3_1\Wyniki. Jako typ geometrii wybierz Poligon, a układ współrzędnych WGS84/ UTM zone 34N. 
Resztę ustawień pozostaw bez zmian i kliknij OK. 

 
Do okna Warstwy zostanie dodany nowo utworzony plik Shapefile. Aby móc rysować nowe obiekty 
w stworzonym pliku wektorowym należy warstwę Poligon włączyć w tryb edycji (PPM > Tryb edycji) 
lub w pasku narzędzi kliknąć ikonę Tryb edycji  . 

 

Następnie narzędziem Rysuj poligon  dostępnym w pasku narzędzi, narysuj kilka poligonów nadając 
im odpowiednie identyfikatory.  

Kolejne wierzchołki poligonu wskazuje się lewym przyciskiem myszy, żeby zakończyć rysowanie 
poligonu, naciśnij prawy przycisk myszy i wpisz identyfikator narysowanego poligonu i kliknij OK.  

Zapisz narysowane poligony używając narzędzia Zapisz edycję  i wyłącz Tryb edycji. 
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4.9. Usuwanie warstw z widoku. 

W celu usunięcia danych rastrowych lub wektorowych z widoku projektu zaznacz wybraną warstwę 
i z menu kontekstowego (PPM) wybierz Usuń warstwę. W celu jednoczesnego usunięcia kilku warstw, 
zaznacz z klawiszem Shift wiele warstw.  

 
Zatwierdź usunięcie warstw i zapisz projekt menu Projekt > Zapisz. 

4.10. Mozaikowanie obrazów Sentinel-2 i przycinanie do wektora w programie QGIS. 

W pierwszej kolejności otwórz przygotowane fragmenty scen Sentinel-2 (10 m rastry składające się 
z kanałów B2, B3, B4 i B8) z folderu MD_3_1\Dane\ 
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S2_20190729_T34UDC_10m_clip.tif  
S2_20190729_T34UEC_10m_clip.tif  

Do mozaikowania rastrów w programie QGIS wykorzystuje się narzędzie z menu Raster > Różne > 
Połącz.   

 
W oknie dialogowym narzędzia Połącz kliknij  i wybierz wczytane fragmenty scen Sentinel-2, 
wybierz typ danych wynikowej mozaiki taki jak danych wejściowych UInt32 oraz wskaż nazwę 
i miejsce zapisu wynikowej mozaiki (Zapisz do pliku…), pozostałe parametry pozostaw bez zmian 
i kliknij Uruchom. 

 
Zmień styl wyświetlania stworzonej mozaiki na barwy naturalne (PPM > Właściwości > Styl). 
Następnie wczytaj do programu QGIS dane wektorowe z granicą obszaru zainteresowania, do którego 
należy przyciąć mozaikę: menu Warstwa > Dodaj warstwę > Dodaj warstwę wektorową i wskaż plik 
Granica.shp lub w polu Przeglądarka kliknij dwukrotnie na plik Granica.shp 
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Zmień styl wyświetlania danych wektorowych na outline red (PPM > Właściwości > Styl) 

 
Przytnij wynikową mozaikę do granicy obszaru zainteresowania wykorzystując narzędzie Przytnij 
raster do maski (menu Raster > Cięcie > Przytnij raster do maski). Jako Warstwę wejściową wybierz 
stworzoną mozaikę, jako Warstwę maski wczytany plik wektorowy z granicą. Zaznacz opcję Dopasuj 
zasięg przycinanego rastra do zasięgu warstwy maski oraz Zachowaj rozdzielczość rastra 
wejściowego. W Przypisz wartość braku danych do kanałów wynikowych wpisz wartość  
999999999 i wybierz nazwę oraz miejsce zapisania wynikowego obrazu. Pozostałe parametry 
pozostaw bez zmian i kliknij Uruchom. 

mailto:michal.pilecki@polsa.gov.pl


                                                                                               

55 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

 
W przypadku nie przypisania wartości braku danych do kanałów, do pikseli „tła” mozaiki (obszaru 
rastra poza granicami obszaru zainteresowania) zostanie przypisana wartość „0” w każdym z kanałów 
rastra. Wówczas tło mozaiki będzie wyświetlane czarnym kolorem. Czarne tło rastra w programie QGIS 
można wyłączyć z wyświetlania ustawiając wartości RGB tła (0, 0, 0) w sposobie wyświetlania rastra 
na 100% przeźroczyste (PPM > Właściwości > Przezroczystość: Dodaj wartości ręcznie). 

Wynikowa mozaika przycięta do granicy obszaru zainteresowania w barwach naturalnych oraz 
fałszywych CIR (z użyciem kanału podczerwieni): 
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5. Pobieranie i korekcja atmosferyczna zobrazowań satelitarnych za pomocą wtyczki  
Semi-Automatic Classification 

Po instalacji wtyczki w panelu głównym pojawi się ikona wtyczki , a w panelu bocznym pod 
panelem Warstwy lub na miejscu Warstwy powinien pojawić się zestaw narzędzi SCP Dock oraz 
dodatkowe menu SCP. Jeżeli zestaw narzędzi lub panel SCP nie jest widoczny, można go włączyć 
klikając PPM w pasek narzędzi i wybierając z menu kontksowego Panele > SCP Dock i/lub Paski 
narzędzi > SCP Edit Toolbar i SCP Working Toolbar 

 

5.1. Pobranie danych satelitarnych Landsat 8. 

Aby móc pobierać dane Landsat 8 za pomocą wtyczki SCP Plugin należy wcześniej założyć konto na 
serwisie USGS / EROS (https://ers.cr.usgs.gov). W analogiczny sposób można za pomocą wtyczki SCP 
Plugin pobierać dane Sentinel korzystając z konta na serwisie Copernicus Open Access Hub lub dane 
z satelitów ASTER i MODIS zakładając konto na serwisie NASA EARTHDATA 
(https://urs.earthdata.nasa.gov).  

Uruchom narzędzie do pobierania danych satelitarnych Download products za pomocą menu SCP > 

Download produts lub klikając w ikonę  w zakładce SCP Dock. W oknie wtyczki Semi-Automatic 
Classification Plugin (SCP) w zakładce Login data uzupełnij swoje dane logowania do serwisu Login 
Landsat. 
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W zakładce Search za pomocą narzędzia Wybierz obszar na mapie zaznacz prostokątem obszar 
zainteresowania AOI (wskazując najpierw prawy dolny narożnik, następnie lewy górny) lub wpisz 
współrzędne geograficzne obszaru zainteresowania AOI. Wybierz satelitę L8 OLI/TIRS (Landsat 8) 
z listy Products. Zawęź czas pozyskania zobrazowania Data od: 01.07.2019 do: 31.08.2019, Maks. 
Pokrycie chmur %: 20 i kliknij Znajdź. 

 
Do pobrania wybierz jedną ze scen Landsat 8 z daty 24.08.2019 i usuń z wyników wyszukiwania 
pozostałe sceny ( ). W celu pobrania zaznacz opcje Wczytaj kanały do QGIS oraz kliknij Run i wskaż 
folder wynikowy: MD_3_1\Wyniki\L8.  
Na etapie pobierania danych zalecane jest również zaznaczenie opcji Wstępna obróbka danych co 
spowoduje, że pobrane dane zostaną automatycznie skorygowane o wpływ atmosfery i ich wartości 
radiometryczne zostaną przeliczone do współczynnika odbicia. 
W zakładce Opcje można natomiast zaznaczyć, które kanały mają być pobierane dla określonych 
zobrazowań (domyślnie pobierane są wszystkie dane). 
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W folderze z pobranym zobrazowaniem Landsat 8 znajdują się pliki TIFF z poszczególnymi kanałami 
spektralnymi obrazu satelitarnego oraz plik tekstowy MTL z metadanymi pobranej sceny Landsat 8.  

Poniżej przedstawiono schemat nazewnictwa pliku z obrazem satelitarnym Landsat 8. 

 
 

5.2. Wstępne przetwarzanie danych satelitarnych Landsat 8. 

W przypadku gdy zobrazowanie satelitarne zostało pobrane przez wtyczkę SCP bez zaznaczonej 
Wstępnej obróbki obrazów lub gdy obraz satelitarny został pobrany na poziomie 1 przetworzenia 
w inny sposób (np. Creodias Finder, EarthExplorer, Copernicus Open Access Hub) należy wykonać 
korekcję atmosferyczną takiego obrazu. 

W celu usunięcia wpływu atmosfery i przeliczenia wartości radiometrycznych do współczynnika 
odbicia Landsat 8 wybierz zakładkę Wstępna Obróbka danych w oknie wtyczki SCP lub przez menu 
SCP > Wstępna obróbka obrazów > Landsat i wybierz folder gdzie znajdują się wszystkie kanały 
obrazu Landsat oraz wskaż plik …MTL.txt  zawierający niezbędne parametry korekcji dla wybranej 
sceny – Select MTL file. Wybierz opcje Zastosuj korekcję atmosferyczną DOS1, resztę ustawień 
pozostaw bez zmian. Uruchom wstępną obróbkę obrazów przyciskiem Run i wskaż folder zapisu dla 
skorygowanych obrazów: MD_3_1\Wyniki\L8_cor. 

 
Pobieranie i korekcję danych satelitarnych za pomocą wtyczki SCP wykonaj również dla dowolnego 
zobrazowania Sentinel-2. 

LC08_L1TP_188024_20190824_20190903_01_T1 

Identyfikator misji 
Landsat i sensora: 

“C”=OLI/TIRS combined, “O”=OLI-only, “T”=TIRS-only, 

“E”=ETM+, “T”=“TM, “M”=MSS 

Numer ścieżki i rzędu sceny 
w systemie Worldwide 

Reference System (WRS)  

Numer kolekcji 
danych Landsat  

Kategoria kolekcji Landsat: 
“RT”=Real-Time, “T1”=Tier 

1, “T2”=Tier 2 

Czas pozyskania  
danych 

Czas przetworzenia 
danych 

Pozom przetworzenia 
(korekcji) 
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