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Opis zadania  

Identyfikacja grup upraw na podstawie klasyfikacji wieloczasowego obrazu satelitarnego Sentinel-2. 

Cel zadania 

Celem poniższej instrukcji jest przybliżenie odbiorcom w jaki sposób wykonać klasyfikację rolniczą na 
wieloczasowych obrazów satelitarnych Sentinel w oprogramowaniu ESA SNAP. 

Wykaz danych przestrzennych GIS 

• Do wykonania klasyfikacji wieloczasowej wykorzystano trzy obrazy z satelity Sentinel-2A  
i Sentinel-2B z roku 2018, dla obszaru znajdującego się w województwie Wielkopolskim. 
Wszystkie obrazy zostały pobrane ze strony Copernicus Open Access Hub, umieszczone  
są w tej samej granuli 33UXT w tracku 122. 

Znajdują się w folderze MD_3_4\Dane: 

06.05.2018: S2A_MSIL2A_20180506T100031_N0207_R122_T33UXT_20180506T105839 
15.07.2018: S2A_MSIL2A_20180715T100031_N0208_R122_T33UXT_20180715T124344 
29.08.2018: S2B_MSIL2A_20180829T100019_N0208_R122_T33UXT_20180829T184909 

• Pliki wektorowe z maskami wybranych upraw: 

Kukurydza: Kukurydza.shp 
Pszenica: Pszenica.shp 
Rzepak: Rzepak.shp 

• Plik wektorowy z maską Corine: CLC_211_2.shp 

 

Wykaz stron internetowych 

• Pobieranie zobrazowań satelitarnych Sentinel-2: https://scihub.copernicus.eu/dhus/#/home 

• Pobieranie danych o pokryciu terenu Corine Land Cover:  
https://land.copernicus.eu/pan-european/corine-land-cover 

Wykaz zastosowanego oprogramowania 

• ESA SNAP 8.0  
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Opis ćwiczenia  
1. Przycięcie obrazu rastrowego 

Dane do projektu w postaci folderów plików z misji Sentinel-2 można wczytać poprzez przeciągnięcie 
całego katalogu do okna Product Explorer. W pierwszym etapie pracy obraz zostanie przycięty  
do mniejszego obszaru, aby skupić się tylko na obszarach rolniczych oraz aby praca przebiegała 
szybciej. Można to wykonać w zakładce Raster > Subset, po uprzednim wybraniu obrazu w oknie 
zawartości. Przycięcie obrazu można ustawić ręcznie na jego miniaturze, która znajduje się w lewym 
górnym rogu okna Subset oraz przez wybór Pixel Coordinates lub Geo Coordinates. Czynność tę 
należy wykonać dla wszystkich obrazów tak, aby każdy mieścił się w tym samym obszarze. W tym 
przypadku wybierz współrzędne pikselowe jak na rysunku poniżej (288, 288, 636, 552), zakładki Band 
Subset, Tie-Point Grid Subset oraz Metadata Subset pozostaw bez zmian. Po wykonaniu operacji w 
oknie zawartości powinny pojawić się nowe pliki z przyciętymi obrazami.  
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Klasyfikacja będzie wykonywana dla upraw rzepaku na obrazie z maja, dla pszenicy na obrazie z lipca 
i dla kukurydzy na obrazie z sierpnia. W pierwszej kolejności przedstawiona zostanie procedura 
wykonania klasyfikacji dla upraw rzepaku na danych z dnia: 06.05.2018r.  

 
2. Pobranie danych Corine Land Cover 

Wykorzystano zobrazowania wykonane w dniach 06 maja, 15 lipca i 29 sierpnia, ponieważ cechowały 
się najmniejszą pokrywą chmur. Wszystkie pochodziły z 2018 roku. Wybrano je, ponieważ każda z dat 
cechuje się odmienną charakterystyką dla upraw rolniczych.  

Rzepak – uproszczony schemat okresu wegetacyjnego rzepaku. Źródło: https://nawozy.eu 
  

 
Rzepak występuje w postaci jarej oraz ozimej. Na badanym obszarze w polach weryfikacyjnych 
znajdowały się tylko odmiany ozime. Najłatwiej jest go odróżnić podczas jego kwitnienia, ponieważ  
w tym czasie rośliny pokryte są jasnożółtymi kwiatami. Zazwyczaj czas zakwitu występuje od początku 
maja i trwa przez dwie pierwsze dekady tego miesiąca, w zależności od położenia na obszarze Polski. 
Do klasyfikacji rzepaku posłużono się obrazem z 06.05.2018 roku. W tym czasie rzepak jest widoczny  
jako jaskrawozielone pola o dość gładkiej strukturze w kompozycji w barwach naturalnych RGB 432. 

 
 
Uprawy zbożowe – uproszczony schemat okresu wegetacyjnego pszenicy. Źródło: https://nawozy.eu 

mailto:michal.pilecki@polsa.gov.pl
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W Polsce uprawy zbożowe występują w dwóch odmianach, jarej i ozimej. Najłatwiej jest odróżnić 
odmiany na obrazach z początku okresu wegetacyjnego - w lutym, kiedy odmiany jare występują jako 
odkryta gleba. Inną metodą jest odróżnienie na przełomie czerwca i lipca, kiedy odmiana ozima jest już 
żółta a jara jeszcze zielona. Uprawy zbożowe szczególnie pszenica posiadają różne odbicie spektralne, 
ponieważ są wymagającą uprawą i dużo zależy od typu nawożenia gleby, na której rośnie i innych 
czynników zewnętrznych, takich jak choroby. Ze wszystkich posiadanych danych, najlepiej jest 
rozróżnialna na obrazie z 15 lipca. Dlatego zaleca się klasyfikować ją najwcześniej na przełomie 
czerwca i lipca, lub w lipcu przed ścięciem. W kompozycji w barwach naturalnych może mieć barwę  
od zielonej, przez ciemnozieloną aż do żółtej lub jasnobrązowej. Dlatego jej klasyfikacja nie jest tak 
oczywista jak w przypadku innych upraw w tym okresie.  

 

 
Kukurydza - Uproszczony schemat okresu wegetacyjnego kukurydzy. Źródło: https://nawozy.eu 

  

mailto:michal.pilecki@polsa.gov.pl


                                                                                               

7 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

Klasyfikacja kukurydzy jest możliwa już na obrazach z końca czerwca, jednak w tym czasie jej odbicie 
spektralne jest podobne do łąk i lasów. Przydatne do porównania był obraz z początku maja, kiedy 
uprawa ta była jeszcze odkrytą glebą. Dlatego w pierwszej kolejności można utworzyć maskę 
obszarów nie będących odkrytą glebą na obrazie z 06.05. Najlepszym okresem do jej klasyfikacji jest 
okres po żniwach. Wtedy inne uprawy są już skoszone i daje to lepszą dokładność klasyfikacji tej 
uprawy. Kukurydzę można wyróżnić po wysokim wskaźniku NDVI, jego wartość powinna mieścić się 
w zakresie od 0.6 do 0.8. Charakterystyczna dla kukurydzy jest jej tekstura. Uprawa ta jest sadzona  
w pasach o dużych odległościach, dlatego na obrazach można zauważyć jej teksturę liniową  
z częściowymi prześwitami do odkrytej gleby. Jest to przydatne do określenia pól treningowych przy 
klasyfikacji 

.  

Aby klasyfikacja miała jak najwyższą dokładność należy wykonać maskę obszarów rolnych,  
tym sposobem na zobrazowaniu pozostaną tylko obszary, na których znajduje się rolnictwo, a reszta 
będzie informacją No data. Informację o tym, gdzie na danym terenie znajdują się obszary rolnicze 
można uzyskać z bazy danych Corine Land Cover, które można pobrać na stronie ESA Coperncius 
https://land.copernicus.eu/pan-european/corine-land-cover. Aby wybrać najnowszą wersję należy 
przejść do okna pod nazwą CLC_2018. W kolejnej zakładce jest opcja download.  

 
Po ściągnięciu warstwy CLC należy z niej wybrać tylko poligony o kodzie 211 w tabeli atrybutów 
CODE_18. Pozwoli to na wyodrębnienie tylko obszarów rolniczych. Ze względu na dużą objętość 
danych i znaczne wydłużenie czasu pracy programu czynność ta została już wcześniej wykonana  
w oprogramowaniu QGIS. W folderze MD_3_4\Dane został umieszczony plik wektorowy 
CLC_211_2.shp. obejmujący obszar poddany do analiz. 

mailto:michal.pilecki@polsa.gov.pl
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Aby załadować dane wektorowe z maską Corine dla obszarów rolniczych należy zaznaczyć przycięty 
obraz klikając na niego LPM i wejść w zakładkę Vector > Import > ESRI Shapefile, w menu głównym.  

 

 
 
 
Przy imporcie pliku wektorowego pojawi się okno dialogowe z informacją o ilości poligonów oraz czy 
załadować je wszystkie jako osobne warstwy. W tym ćwiczeniu chcemy mieć jedną warstwę maski – 
kliknij No. 
 

 
 
 
Plik shapefile pojawi się w danych zaznaczonego obrazu w zakładce Vector Data, a także w zakładce 
Masks.  
By wyświetlić obraz w kolorach RGB kliknij PPM na obraz i wybierz polecenie Open RGB Image 
Window. W oknie Select RGB-Image Channels pozostaw domyślne ustawienia. Zmieniając Profile 
możesz ustawić jeden z domyślnych zestawów kanałów lub własnoręcznie zmienić Red, Green, Blue. 
Zatwierdź przyciskiem OK.  

mailto:michal.pilecki@polsa.gov.pl
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Wykonaj import pliku CLC_211_2.shp dla każdego z obrazów oraz wyświetl je w kolorystyce barw 
naturalnych RGB. 

Widok obrazu w kolorach naturalnych RGB wraz z maską upraw.  
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3. Utworzenie masek 

Posiadanie danych dla obszarów rolniczych pozwoli na utworzenie maski. Jest to możliwe w zakładce 
Raster > Masks > Land/Sea Mask. W opcjach I/O Parameters wybieramy odpowiedni obraz i ścieżkę 
oraz nazwę zapisu. W Processing Parameters wybieramy kanały, na których ma zostać wykonana 
maska (zalecane się wybrać kanały o tej samej rozdzielczości (GSD 10 m): B2, B3, B4 i B8) oraz opcję 
Use Vector Mask. Pojawia się opcja wyboru odpowiedniego shapefile z maską. Wymaskowany obraz 
powinien posiadać tylko informację o obszarach rolniczych, reszta obrazu to raster z informacją No 
Data. 

 
Widok obrazu przedstawiony w kolorystyce barw naturalnych po nałożeniu maski upraw.  
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W celu uzyskania poprawnej klasyfikacji wykonaj reprojekcje zobrazowań do układu WGS84. Wybierz 
polecenie Raster > Geometric > Reprojection. Wybierz obraz i ścieżkę zapisu, oraz układ 
współrzędnych (WGS 84).   

 
 

4. Tworzenie obszarów zainteresowania (ROI) 

Gdy już wszystkie obrazy są wymaskowane, kolejnym etapem jest tworzenie ROI (ang. region  
of interest), czyli poligonów wzorcowych do przyszłej klasyfikacji. W tym celu na obrazie, na którym 
będzie wykonywana klasyfikacja (w tym przypadku obraz po reprojekcji z dnia 06.05.2018), należy 
wybrać funkcję Vector > New Vector Data Container, po czym utworzyć nowy wektor, o nazwie 
odpowiedniej uprawy rolniczej. Utworzony wektor powinny pojawić się w oknie zawartości w folderze 
Vector Data 

 
 

5. Tworzenie pól treningowych do klasyfikacji 

Aby dokładność klasyfikacji była jak najwyższa należy utworzyć kilkanaście poligonów dla każdej  
z klas (min. 10), muszą one być nieduże i przedstawiać tylko wzorcowe odbicie spektralne dla każdej  

mailto:michal.pilecki@polsa.gov.pl
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z upraw. Poligony dla każdej klasy powinny stanowić co najmniej 1% obrazu i być rozmieszczone, jeżeli 
to możliwe, w każdej jego części.  

Poligony można stworzyć klikając na utworzoną warstwę wektorową i ikonę narzędzi rysowania.  
W przypadku trudności z identyfikacją odpowiednich upraw wczytaj pliki z wykonaną już wcześniej 
klasyfikacją (Kukurydza.shp, Pszenica.shp i Rzepak.shp) i na ich podstawie zdefiniuj pola treningowe.  
 

  
 

 
 
Utworzoną warstwę wyeksportuj do formatu shapefile pod zmienioną nazwą (np. dodając indeks) oraz 
ponownie je zaimportuj. Kliknij PPM na daną warstwę wektorową, a następnie Vector > Export > 
Geometry as a Shapefile. 
 

 
 
Import warstwy wykonaj klikając PPM na cały zestaw danych, a następnie Vector > Import > ESRI 
Shapefile. 

mailto:michal.pilecki@polsa.gov.pl
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By uniknąć pomyłek usuń pierwsze warstwy ROI i pozostaw te nowo zaimportowane.  
 

6. Klasyfikacja 

Po utworzeniu wzorcowych poligonów kolejnym etapem jest klasyfikacja. W zakładce Raster > 
Classification wybieramy klasyfikację nadzorowaną (Supervised Classification), czyli taką, gdzie sami 
określamy poligony do wzorców tak jak to zostało zrobione w poprzednim kroku. Zastosujemy jedną  
z najbardziej znanych metod analizy danych teledetekcyjnych wykorzystywanych w klasyfikacji obrazu 
Maximum Likelihood Classifier. 

 
Po otwarciu okna klasyfikacji w pierwszej kolejności należy wybrać obraz, na którym ta operacja 
zostanie wykonana i oznaczyć go, aby podświetlał się na niebiesko. Jako zbiór do klasyfikacji 
wybieramy dane po reprojekcji z wektorami CLC i ROI danej uprawy (po eksporcie/imporcie), program 
automatycznie dodaje do nazwy przyrostek reprojected. W zakładce Maximum-Likelihood-Classifier 
wybieramy opcję Train on Vectors, Number of Training Samples zaleca się, aby pozostawić 
domyślnie. Następnie wybieramy poligony, które wcześniej utworzyliśmy oraz kanały, na których 
klasyfikacja ma zostać wykonana. Poligony i warstwy muszą się podświetlać na niebiesko. W ostatniej 
zakładce Write wybieramy nazwę nowego pliku i jego ścieżkę zapisu, zalecany format to GeoTiff.  
Po kliknięciu przycisku Run utworzy się nowy plik w oknie zawartości. Aby go wyświetlić należy przejść 
do folderu Bands i wybrać LabelledClasses. Dzięki temu w oknie podglądu wyświetli się wykonana 
klasyfikacja. 
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Wynik klasyfikacji rzepaku: 
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Na powyższej rycinie przedstawiona jest klasyfikacja rzepaku, zaznaczona na kolor zielony. W oknie 
podglądu można podejrzeć informacje o nazwie klas, zmienić ich kolor oraz zobaczyć jaki procent całej 
klasyfikacji stanowi dana klasa. 

 
Klasyfikację upraw (od punktu 1 – wczytania i przycięcia danych do 6 – klasyfikacji) należy wykonać 
jeszcze dla obrazu z lipca, aby sklasyfikować uprawy zbożowe oraz dla obrazu z sierpnia,  
aby sklasyfikować kukurydzę.  

Po wykonaniu trzech klasyfikacji, ich wyniki przekonwertowano z wersji rastrowej na wektorową 
(Kukurydza.shp, Pszenica.shp i Rzepak.shp). Obraz poniżej przedstawia wynik klasyfikacji dla trzech 
rodzajów upraw. Kolorem żółtym oznaczone są poligony, gdzie został zaklasyfikowany rzepak, kolorem 
brązowym – uprawy pszeniczne, kolorem zielonym – kukurydza. Podkład do klasyfikacji stanowi obraz 
z maja, bez uwzględnienia maski rolniczej.  
 

 
 
By porównać wyniki różnych klasyfikacji wykonaj w analogiczny sposób np. klasyfikację nadzorowaną 
Minimum Distance Classifier. Wybierz z panelu głównego Raster > Classification > Supervised 
Classification > Minimum Distance Classifier.  
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Można wykonać również klasyfikację nienadzorowaną np. K-means wybierając Raster > Classification 
> Unsupervised Classification > K-means Cluster Analysis. Zapisz plik do formatu GeoTIFF, 
parametry w zakładce Processing Parameters pozostaw bez zmian. Obszar zostanie podzielony  
na klasy, z których następnie należy wybrać klasę rzepaku (w przypadku innych zobrazowań kukurydzy 
i pszenicy). 
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