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Opis zadania  

W skutek nawałnic, które w nocy z 11 na 12 sierpnia 2017 r. spustoszyły lasy kilkudziesięciu 
nadleśnictw w północnej Polsce zniszczeniu uległo niemal 120 tys. ha lasów. W przypadku tego 
rodzaju zjawisk ekstremalnych bardzo ważne jest szybkie dostarczenie informacji o zasięgu uszkodzeń. 
Pomaga to w oszacowaniu szkód w wymiarze miąższościowym i odpowiednim zaplanowaniu prac 
leśnych. Zadanie polega na określeniu wielkości szkód pohuraganowych. Zadanie opiera się na 
porównaniu dwóch zobrazowań satelitarnych Sentinel-1 po wcześniejszym ich przetworzeniu. 
Zobrazowania pochodzą sprzed i po wystąpieniu huraganu. 

Cel zadania 

• analiza zobrazowań radarowych dla drzewostanów w okresie przed oraz po wystąpieniu 
uszkodzeń pohuraganowych 

• obliczenie powierzchni szkód dla wybranego obszaru. 

Wykaz danych przestrzennych GIS 

• zobrazowania satelitarne satelity Sentinel-1 (Level-1 GRD) pozyskane w dniach:  
02.08.2017: 
S1A_IW_GRDH_1SDV_20170802T163555_20170802T163620_017747_01DBA1_C11D.SAFE 
14.08.2017: 
S1A_IW_GRDH_1SDV_20170814T163556_20170814T163621_017922_01E0F5_6F67.SAFE 
 

• plik zawierający granice wydzieleń Nadleśnictwa Rytel oraz Czersk (BDL): LMN.shp 
 
• zobrazowanie satelitarne satelity Sentinel-2 (L2A) pozyskane w dniu 29.09.2017: 

20170928_S2.tif 

Wykaz stron internetowych 

• Pobieranie zobrazowań satelitarnych Sentinel-2:  
https://scihub.copernicus.eu/dhus/#/home 

Wykaz zastosowanego oprogramowania 

• SNAP 8.0 
• QGIS 3.16 
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Opis ćwiczenia  
1. Wczytanie zobrazowań satelitarnych do programu SNAP 

Interfejs programu składa się z kilku elementów, z których zasadniczą część stanowi okno wyświetlania 
danych (2) oraz okno, w którym wyświetlana jest lista zobrazowań wczytanych do projektu (1). 
W górnym pasku (3) widoczne są narzędzia z aktualnie włączonych pasków narzędziowych. 

 

W celu dodania zobrazowań satelitarnych do programu SNAP wybierz opcję File > Open Product 
 a następnie wskaż plik manifest.safe, znajdujący się w folderze z zobrazowaniem 

satelitarnym.  
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Lista wczytanych zobrazowań pojawia się w oknie Product Explorer. 

 
W sytuacji, gdy okno Product Explorer zostanie przypadkowo zamknięte, możne je ponownie otworzyć 
korzystając z opcji View > Tool Windows > Product Explorer. 

W ćwiczeniu wyświetl obrazy Amplitude_VH oraz Amplitude_VV dla każdej importowanej rejestracji. 

2. Ograniczenie zasięgu zobrazowań satelitarnych do wybranego obszaru 

Ponieważ sceny satelitarne Sentinel-1 zajmują stosunkowo duży obszar, zdecydowano się ograniczyć 
zasięg analizowanego obszaru do fragmentów Nadleśnictwa Rytel oraz Czersk.  

Wskaż lewym przyciskiem myszy (LPM) zobrazowanie z dnia 02-08-2017 w oknie Product Explorer, 
a następnie wybierz opcję Raster > Subset. W oknie narzędzia Subset wybierz zakładkę Spatial 
Subset i zdefiniuj współrzędne prostokąta, który zostanie wykorzystany do ograniczenia zasięgu 
zobrazowania przechodząc do zakładki Pixel Coordinates: 

North latitude bound: 12300 
West longitude bound: 7000 
South latitude bound: 17000 
East longitude bound: 9600 

 
W zakładce Band Subset wybierz podzbiór obrazów wchodzących w skład danego produktu 
w odniesieniu do układu polaryzacyjnego VV i VH. Do celów ćwiczenia zaznacz Amplitude_VH 
i Amplitude_VV.  

mailto:michal.pilecki@polsa.gov.pl
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W zakładce Tie-Point Grid Subset można wybrać podzbiór obrazów pomocniczych, które zostały 
wygenerowane automatycznie przez program na podstawie metadanych. W zakładce Metadata 
Subset można wybrać podzbiór metadanych produktu źródłowego. Do celów ćwiczenia ustawienia 
dwóch ostatnich zakładek można pozostawić domyślne. 

Nowoutworzony podzbiór danych wyświetlany jest w menadżerze produktów pod nazwą 
subset_X_of_Y, gdzie X to numer podzbioru, Y to nazwa danych, z których pochodzi podzbiór. Dane 
przechowywane są w pamięci podręcznej i należy je zapisać na dysk lokalny do folderu ćwiczeniowego. 
Produkty zapisuje się klikając prawym przyciskiem na nazwę nowostworzonego produktu 
(subset_X_of_XXXXXXX) i wybierając polecenie Save Product As. W celu sprawniejszej identyfikacji 
danych skróć nazwę pliku do następującej postaci: 

 
Po zapisaniu plików zaleca się zamknięcie wszystkich produktów w programie, a następnie otworzenie 
ponownie ostatnio zapisanych plików.  

Produkty zamyka się wybierając w głównym pasku narzędzi File > Close All Products. 
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3. Uaktualnienie danych orbitalnych 

Do aktualizacji danych orbitalnych mających na celu poprawienie geometrii obrazów niezbędne jest 
podłączenie do sieci internetowej. Program automatycznie pobierze odpowiednie pliki do aktualizacji 
danych orbitalnych.  

W głównym pasku narzędzi wybierz Radar > Apply Orbit File.  W zakładce I/O Parameters w polu 
Source Product wskaż pojedynczo otwarte w programie dane.  Dla każdej rejestracji nazwę pliku 
wynikowego pozostaw domyślną oraz wskaż format Save As: BEAM-DIMAP i miejsce zapisu na dysku 
(MD_3_3\Wyniki).  W zakładce Processing Parameters w polu Orbit State Vector wskaż typ danych 
orbitalnych wybierając orbity precyzyjne: Sentinel Precise (Auto Download) oraz rekomendowany 
stopień wielomianu Polynomial Degree: 3.  Po ustawieniu parametrów procesu kliknij Run. 

 

 
4. Usuwanie addytywnego szumu termicznego 

Na wielu obrazach GRD można zauważyć obecność addytywnego szumu termicznego, szczególnie 
w obszarach o niskim rozproszeniu wstecznym (takich jak spokojne morze, jeziora itp.). Szum termiczny 
wynika z techniki obrazowania progresywnym skanerem TOPSAR (Terrain Observation with 
Progressive Scans SAR) i jest ledwo zauważalny, ale staje się istotny wtedy, gdy średnia sygnału jest 
niska.  

W celu usunięcia addytywnego szumu termicznego występującego na obrazach intensywności, 
szczególnie w polaryzacji krzyżowej, użyj funkcji z głównego menu Radar > Radiometric > S1 Thermal 
Noise Removal niezależnie dla każdej rejestracji. W zakładce I/O Parameters w polu Source Product 
wskaż pojedynczo dane NazwaObiektu_DataRejestracji_Orb. Dla każdej rejestracji nazwę pliku 
wynikowego pozostaw domyślnie oraz wskaż format Save As: BEAM-DIMAP i miejsce zapisu na 
dysku (MD_3_3\Wyniki). W zakładce Processing Parameters w polu Polarisations wskaż polaryzację 
VH i VV i zaznacz opcję usunięcia szumu termicznego: Remove Thermal Noise. Po ustawieniu 
parametrów procesu kliknij Run. 

mailto:michal.pilecki@polsa.gov.pl
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Po tym i kolejnych etapach przetworzenia warto zwizualizować sobie kanał z jedną z polaryzacji nowo 
utworzonego produktu, np. VV i porównać z produktem na podstawie, którego powstał, aby sprawdzić 
efekt działania użytego narzędzia. Poniżej grafika przedstawiająca polaryzację VV przed (po lewej) i po 
(po prawej) usunięciu addytywnego szumu termicznego. 

 
Aby wyświetlić dwa obrazy jednocześnie należy nacisnąć narzędzie Tile Horizontally 
znajdujące się na pasku narzędzi. 

Dodatkowo włączone opcje: Synchronise view oraz Synchronise cursor znajdujące się w lewym 
dolnym okienku w zakładce Navigation, ułatwiają porównywanie danych. 

mailto:michal.pilecki@polsa.gov.pl
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5. Kalibracja radiometryczna 

Obraz radarowy jest rozkładem stosunku energii sygnału wysłanego do energii odbitej (echa 
radarowego). Stosunek ten nazywany jest współczynnikiem rozpraszania wstecznego (ang. 
backscattering coefficient) i podlega procesowi kalibracji tzw. kalibracji radiometrycznej. 
Przeprowadzenie kalibracji radiometrycznej eliminuje czynniki związane z geometrią obrazowania 
i umożliwia m.in porównanie danych radarowych pochodzących z różnych sensorów, rejestrowanych 
w różnych trybach obrazowania, w różnym czasie i generowanych przez różne procesory. 
Współczynnik rozpraszania wstecznego może być wyrażany za pomocą Beta Nought, Sigma Nought 
i Gamma Nought. Najczęściej stosuje się Sigma Nought. 

Kalibrację radiometryczną danych w postaci amplitudy do postaci Sigma Nought wykonaj niezależnie 
dla każdej rejestracji korzystając z narzędzia Radar > Radiometic > Calibrate. W zakładce I/O 
Parameters w polu Source Product wskaż pojedynczo dane 
NazwaObiektu_DataRejestracji_Orb_TNR. Dla każdej rejestracji nazwę pliku wynikowego pozostaw 
domyślną oraz wskaż format Save As: BEAM-DIMAP i miejsce zapisu na dysku (MD_3_3\Wyniki). 
W zakładce Processing Parameters w polu Polarisations wskaż polaryzację VH i VV, a następnie 
zaznacz opcję generowania obrazu wstecznego współczynnika rozpraszania w postaci Sigma Nought: 
Output sigma0 band. Po ustawieniu parametrów procesu kliknij Run. 

mailto:michal.pilecki@polsa.gov.pl


                                                                                               

10 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

 
 

 

 
6. Filtracja efektu plamkowania 

Obrazowanie radarowe charakteryzuje się dużą zmiennością wartości sąsiadujących pikseli. Jest to tak 
zwany efekt plamkowania (ang. speckle effect), potocznie nazywany również efektem soli i pieprzu. 
W celu zredukowania efektu plamkowania wykonuje się filtrację obrazów. Filtracje mogą opierać się 
na różnych rozkładach np. normalnym (Gaussa) lub gamma. Wśród prostych metod filtracji wyróżnia 
się filtry oparte na średniej arytmetycznej (Boxcar) i medianie (Median). Do bardziej złożonych metod 
stosowanych do danych radarowych zalicza się metody takie jak Lee, Frost, IDAN, Gamma-MAP. 
Niestety nie istnieje idealny filtr, który spowodowałby wygładzenie obszarów homogenicznych przy 
zachowaniu pełnej szczegółowości i rozdzielczości. Wybór metody filtracji zależy całkowicie od 
użytkownika. Na potrzeby niniejszego zadania została wybrana metoda filtracji Lee Sigma. Filtr ten jest 
oparty na modelu rozkładu Gaussa i uśrednia tylko piksele w określonym zakresie odchyleń 
standardowych.  

W głównym pasku narzędzi wybierz Radar > Speckle Filtering > Single Product Speckle Filter. 
W zakładce I/O Parameters w polu Source Product wskaż dane po kalibracji radiometrycznej, a w polu 
Target Product nazwę pliku wynikowego pozostaw domyślną oraz wskaż format Save As: BEAM-
DIMAP i miejsce zapisu na dysku (MD_3_3\Wyniki).  W zakładce Processing Parameters w polu 
Source Band wskaż wszystkie kanały polaryzacji i wybierz metodę filtracji Filter: Lee Sigma, Windows 
size: 11x11, a pozostałe parametry pozostaw domyślne. Po ustawieniu parametrów kliknij Run. 
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7. Konwersja danych do formatu ośmiobitowego (int8) 

Przekonwertuj wartości współczynnika odbicia wstecznego do formatu ośmiobitowego (int8): Raster 
> Data Conversion > Convert-Datatype. W zakładce I/O Parameters w polu Source Product wskaż 
dane po filtracji efektu plamkowania, a w polu Target Product nazwę pliku wynikowego pozostaw 
domyślną oraz wskaż format Save As: BEAM-DIMAP i miejsce zapisu na dysku (MD_3_3\Wyniki). 
W zakładce Processing Parameters w polu Source Band wskaż wszystkie kanały polaryzacji i wybierz 
Target Data Type: uint8, a pozostałe parametry pozostaw domyślne. Po ustawieniu parametrów 
kliknij Run. 
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8. Geokodowanie – transformacja obrazu do układu kartograficznego 

Transformację do układu kartograficznego wykonaj stosując narzędzie Radar > Geometric > Terrain 
Correction > Range-Doppler Terrain Correction. W zakładce I/O Parameters w polu Source Product 
wskaż dane po przeprowadzonej konwersji do formatu ośmiobitowego w polu Target Product nazwę 
pliku wynikowego pozostaw domyślną oraz wskaż format Save As: BEAM-DIMAP i miejsce zapisu na 
dysku (MD_3_3\Wyniki). W zakładce Processing Parameters w polu Source Band wskaż wszystkie 
obrazy Sigma0, w polu numerycznego modelu terenu Digital Elevation Model wskaż: SRTM 3Sec 
(Auto Download). Jako metodę przepróbkowania DEM DEM resampling method wybierz: Bilinear 
Interpolation, tak samo jak w przypadku metody przepróbkowania obrazów transformowanych Image 
Resampling Method. Wymiar piksela docelowego Pixel spacing to 10 m w układzie współrzędnych 
geograficznych Map projection: UTM / WGS 84 (Automatic). Dodatkowo odznacz Mask out areas 
with no elevation. Po ustawieniu parametrów kliknij Run. 

 

 
 
 

Czynności opisane po kolei w rozdziałach 1-8 powtórz dla zobrazowania z drugiego terminu. 
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9. Korejestracja 

Kluczowym elementem w analizach zbiorów wieloczasowych jest dokładne dopasowanie 
geometryczne obrazów tzw. korejestracja. Korejestracja wykonywana jest w oparciu o dane orbitalne 
i wartości pikseli.  

Przed przystąpieniem do wykonania korejestracji wyświetl kanał z polaryzacją VV razem dla dwóch 
terminów i spróbuj zlokalizować obszar dotknięty klęską. Następnie czynność tę powtórz dla 
polaryzacji VH i oceń, która polaryzacja będzie lepsza to wyznaczenia wielkości szkód. 

W celu wykonania korejestracji wybierz z narzędzi Radar > Coregistration > Coregistration. 
W zakładce ProductSet-Reader za pomocą ikony plusa dodaj do listy produkty, które mają zostać 
poddane korejestracji tzn. pliki o nazwie NazwaObiektu_DataRejestracji_Orb_tnr_Cal_Spk_Cnv_TC 
powstałe w wyniku przeprowadzonej wcześniej korekcji geometrycznej. Pierwsza rejestracja na liście 
oznacza obraz referencyjny tzw. master, do którego zostaną korejestrowane pozostałe obrazy tzw. 
slaves. Kolejność plików na liście można zmieniać poprzez użycie ikon strzałek skierowanych w górę 
lub w dół, a same pliki wejściowe dodajemy poprzez ikonę plusa. W zakładce CreateStack, Cross-
Correlation i Warp pozostaw domyślne ustawienia narzędzia.  
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10. Przycięcie zobrazowania do maski lasu 

Aby załadować dane wektorowe z maską lasu należy zaznaczyć przycinany obraz klikając na niego 
lewym przyciskiem myszy i wejść w zakładkę Vector > Import > ESRI Shapefile, w menu głównym. 

 
 
Wskazujemy plik LMN.shp. Po zatwierdzeniu pojawi się komunikat z zapytaniem czy każdy poligon ma 
być wczytany jako osobna warstwa, wskazujemy odpowiedź No. 

 
Po rozwinięciu produktu w okienku Product explorer nowa warstwa pojawi się w zakładce Vector 
Data. 
Przycięcie zobrazowania warstwą wektorową jest możliwe w zakładce Raster > Masks > Land/Sea 
Mask. W opcjach I/O Parameters wybieramy odpowiedni produkt  i ścieżkę oraz nazwę zapisu pliku 
wynikowego. W Processing Parameters wybieramy kanały, na których ma zostać wykonana maska 
(zaznaczyć wszystkie kanały) oraz opcję Use Vector Mask. Pojawia się opcja wyboru odpowiedniego 
shapefile z maską. Wymaskowany obraz powinien posiadać tylko informację o obszarach leśnych, 
reszta obrazu powinna przechowywać informację No Data. 
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11. Wyświetlenie kompozycji barwnej 

W Product Explorer kliknij na nazwę przyciętego do granic lasu zobrazowania, a następnie w menu 
głównym wybierz Window > Open RGB Image Window. Jako składowe RGB wczytaj:  
RED: Sigma0_VV_slv2_14Aug2017,  
GREEN: Sigma0_VV_mst_02Aug2017,  
BLUE: Sigma0_VV_mst_02Aug2017. 
 

 
 
Aby wyłączyć wyświetlanie warstwy wektorowej należy przejść do Layer Manager i odznaczyć Vector 
data: 
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Dzięki takiemu ustawieniu kanałów w kompozycji barwnej kolorem czerwonym zostaną przedstawione 
obszary, które uległy zniszczeniu podczas huraganu: 

 
 

12. Klasyfikacja nienadzorowana 

Wyznaczenie powierzchni uszkodzonych drzewostanów może odbywać się na kilka sposobów. 
Podczas niniejszego ćwiczenia zostanie zaprezentowana metoda klasyfikacji nienadzorowanej. 
W zakładce Raster > Classification wybieramy klasyfikację nienadzorowaną (Unsupervised 
Classification), czyli taką, gdzie wskazujemy tylko na ile klas ma zostać podzielony dany obszar. 
Zostanie wykorzystany algorytm K-Means Cluster Analysis. 
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W zakładce I/O Parameters wskazujemy plik źródłowy, nazwę oraz miejsce zapisu pliku wynikowego, 
a także zmieniamy format zapisu na GeoTIFF. W kolejnej zakładce: Processing Parameters zmieniamy 
parametr Number of Clusters: 4, a w Source band names zaznaczamy tylko kanały z polaryzacją 
wertykalną:  Sigma0_VV_mst_02Aug2017, Sigma0_VV_slv2_14Aug2017. 

 
 
Zadaniem użytkownika jest zinterpretowanie powstałych klas. Aby wyświetlić wynik klasyfikacji 
rozwiń nowo powstały produkt w okienku Product Explorer, następnie Bands i dwukrotnie kliknij LPM 
na class_indices. Odnajdź klasę z uszkodzonymi drzewostanami i w okienku Color Manipulation zmień 
barwę klasy na czerwoną, a pozostałym klasom nadaj białą barwę. 
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13. Wyświetlenie wyniku w programie QGIS 

Otwórz program Qgis i wczytaj przycięte zobrazowanie Sentinel 2 z 29.08.2017 r. i wzmocnij kontrast 
do pełnego zakresu danych: 

 
 
Następnie wczytaj wynik klasyfikacji nienadzorowanej i zmień sposób wyświetlania, tak aby widoczna 
była tylko klasa z uszkodzonymi drzewostanami. Aby to zrobić przejdź do jej Właściwości > Styl, 
następnie kliknij przycisk Klasyfikuj, z naciśniętym przyciskiem Ctrl zaznacz wszystkie klasy poza tą 
z uszkodzonymi drzewostanami i kliknij Usuń zaznaczone wiersze, na końcu zmień kolor 
pozostawionej klasy na czerwony i zatwierdź zmiany przyciskiem OK. 
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14. Obliczenie powierzchni uszkodzonych drzewostanów 

W celu określenia powierzchni uszkodzonych drzewostanów wybierz zakładkę Processing i pole Panel 
algorytmów. W ten sposób w prawej części ekranu otworzona zostanie zakładka Algorytmy 
Processingu następnie z zakładki Raster – analiza wybierz pole Raport unikalnych wartości rastra. 
W nowo otwartym oknie w zakładce Warstwa źródłowa wybierz warstwę z wynikiem klasyfikacji, 
a następnie w zakładce Raport unikalnych wartości wybierz pole (...), a następnie z menu podręcznego 
wybierz pole Zapisz do pliku.... Następnie w oknie Zapisz plik wskaż nazwę pliku i miejsce zapisu 
(zalecany wybór folderu to MD_3_3/Wyniki) oraz wybierz pole Zapisz. Na koniec kliknij pole Uruchom. 
Aby zobaczyć Raport unikalnych wyników otwórz nowo powstały plik. 
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Zaletą danych radarowych jest to, że są generowane na podstawie fal radiowych, których długość 
zapewnia brak wrażliwości na warunki atmosferyczne (np. zachmurzenie) w przeciwieństwie do 
danych optycznych, które z kolei posiadają większą szczegółowość obrazu przy takiej samej 
rozdzielczości przestrzennej, przez co dają dokładniejszy wynik w przypadku określania szkód 
pohuraganowych. Zarówno Sentinel-1 oraz Sentinel-2 posiadają podobną rozdzielczość czasową, 
jednak dane optyczne nie zawsze nadają się do analiz i w przypadku potrzeby szybkiej informacji 
pomocne są dane radarowe, które mogą wstępnie wskazać powierzchnie wyrządzonych szkód, co 
z kolei może być pomocne przy planowaniu nalotów fotogrametrycznych, które są kosztowne, 
a informacja o potencjalnym  zasięgu szkód pozwoli zminimalizować koszty. 
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