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Opis zadania  

W listopadzie 2019 roku wyjątkowo obfite opady w Wielkiej Brytanii doprowadziły do powodzi, 
powodując tym samym ogromne szkody. Doszło do powodzi w rejonach wód powierzchniowych i rzek 
w częściach Yorkshire, Nottinghamshire, Greater Manchester, Derbyshire i Lincolnshire. Dzięki 
możliwości obrazowania niezależnie od warunków pogodowych i oświetleniowych satelitarna 
teledetekcja radarowa okazuje się przydatnym narzędziem do wyznaczenia zasięgów powodzi. 
Obecnie nieograniczony i bezpłatny dostęp do satelitarnych danych radarowych z misji Sentinel-1A/B 
uatrakcyjnia wybór tej metody. Dodatkowym atutem jest możliwość badań na dużych obszarach. 

 
Obszar opracowania (Google Earth) 

 

Obszary powodziowe w Barlings, Lincolnshire (UK) 2019. 
Fot. Geoff Robinson 

(https://www.telegraph.co.uk/news/2019/11/13/uk-
weatherflooded-farmer-says-could-12-months-can-plant-

crops/) 

 

Obszary powodziowe w Fishlake (UK) 2019. Fot. 
Christopher Furlong/Getty 

(https://www.telegraph.co.uk/news/2019/11/13/uk-
weatherflooded-farmer-says-could-12-months-can-plant-

crops/) 

Zadanie polega na identyfikacji powierzchni wody na amplitudowych obrazach radarowych 
zarejestrowanych przed powodzią i w czasie powodzi. Obraz sprzed powodzi wyznacza stan stałych 
wód powierzchniowych. Obrazy pozyskane w czasie powodzi wyznaczają powierzchnie powodziowe 
na stan rejestracji. Zadanie obejmuje dwa etapy: wstępne przetworzenie danych Senetinel-1 (punkty 
1-9) i wyznaczenie obszarów powodziowych (punkty 10-12). Wstępne przetworzenie danych 
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Sentinel-1 do postaci ortoobrazów wstecznego współczynnika rozpraszania (ang. Sigma Nought) 
zostanie wykonane krok po kroku i będzie obejmowało: importowanie danych, wybór obszaru 
opracowania, uaktualnienie danych orbitalnych, usunięcie addytywnego szumu termicznego, kalibrację 
radiometryczną, korejestrację, filtracje efektu plamkowania, konwersję ze skali liniowej do 
logarytmicznej i geokodowanie. Wyznaczenie obszarów powodziowych będzie polegało na 
wyodrębnieniu pikseli zidentyfikowanych jako powierzchnie wody zakładając, że powierzchnie wody 
są gładkimi powierzchniami od których fale radarowe odbijają się w kierunku przeciwnym niż fale 
wysyłane, tym samym będąc najciemniejszymi pikselami na obrazach. 

Cel zadania 

Celem tego ćwiczenia jest wyznaczenie zasięgów powodzi na podstawie teledetekcyjnych danych 
radarowych Sentinel-1 A/B. 

Wykaz danych przestrzennych GIS 

Dane znajdują się w folderze MD_3_2\Dane 
• Trzy produkty GRD z misji Sentinel-1 zarejestrowane w dniu 5 listopada 2019 (przed 

powodzią), 11 listopada 2019 i 17 listopada 2019 (w czasie powodzi): 
05.11.2019: 

S1A_IW_GRDH_1SDV_20191105T175014_20191105T175039_029779_03650F_C0E7.zip 
11.11.2019: 

S1A_IW_GRDH_1SDV_20191117T175014_20191117T175039_029954_036B31_71F5.zip 
17.11.2019: 

S1B_IW_GRDH_1SDV_20191111T174926_20191111T174951_018883_0239D1_4174.zip 
• Poligon testowy powierzchni wody: Water_ROI_Polygon_Polygon.shp 

Wykaz stron internetowych 

• Pobieranie pliku instalacyjnego Google Earth: 
https://www.google.pl/intl/pl/earth/download/gep/agree.html 

Wykaz zastosowanego oprogramowania 

• SNAP 8.0  
• Google Earth Pro  

mailto:michal.pilecki@polsa.gov.pl
https://www.google.pl/intl/pl/earth/download/gep/agree.html


                                                                                               

5 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

 

Opis ćwiczenia  

1. Importowanie źródłowych danych Sentinel-1 

W głównym pasku narzędzi wybierz File > Open Product lub File > Import > SAR Sensors > 
SENTINEL-1 i wskaż spakowane dane *.zip trzech rejestracji i kliknij Open 
S1A_IW_GRDH_1SDV_20191105T175014_20191105T175039_029779_03650F_C0E7.zip 
S1A_IW_GRDH_1SDV_20191117T175014_20191117T175039_029954_036B31_71F5.zip 
S1B_IW_GRDH_1SDV_20191111T174926_20191111T174951_018883_0239D1_4174.zip 

 
W celu sprawdzenia poprawności wykonanego importu wyświetl każdy importowany obraz i oceń 
wizualnie czy jest prawidłowo wyświetlony. Obrazy wyświetla się klikając dwukrotnie na nazwę 
kanału Bands w danym produkcie z listy w menadżerze produktów Product Explorer. 
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W ćwiczeniu wyświetl obrazy Amplitude_VH dla każdej importowanej rejestracji. 

 
2. Wybór obszaru opracowania 

W celu wyboru obszaru opracowania najpierw zaznacz odpowiedni produkt w menadżerze danych 
Product Explorer, a następnie wybierz Raster > Subset w głównym pasku narzędzi. 

W zakładce Spatial Subset (Geo Coordinates) określ zasięg przestrzenny obszaru opracowania 
podając minimalne i maksymalne współrzędne pikselowe lub geograficzne granic obszaru. Do celów 
ćwiczenia wybierz współrzędne geograficzne Geo Coordinates przyjmując:  

North Latitude bound: 53.458,  
West longitude bound: -1.172,  
South Latitude bound: 53.894,  
East longitude bound: -0.535. 

W zakładce Band Subset wybierz podzbiór obrazów wchodzących w skład danego produktu 
w odniesieniu do układu polaryzacyjnego VV i VH. Do celów ćwiczenia zaznacz Amplitude_VH. 

W zakładce Tie-Point Grid Subset można wybrać podzbiór obrazów pomocniczych, które zostały 
wygenerowane automatycznie przez program na podstawie metadanych. Do obrazów pomocniczych 
zalicza się obrazy przedstawiające długość longitude i szerokość latitude geograficzną, kąt padania 
wiązki radarowej do normalnej w odniesieniu do elipsoidy incidence_angle, kąt wziesienia między 
wiązką radarową kierunkiem do nadiru elevation_angle i czas slant_range_time. Do celów ćwiczenia 
wybierz wszystkie obrazy pomocnicze. 

W zakładce Metadata Subset można wybrać podzbiór metadanych produktu źródłowego. Do celów 
ćwiczenia wybierz wszystkie metadane. 

Po ustawieniu parametrów procesu kliknij OK. 
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Nowoutworzony podzbiór danych wyświetlany jest w menadżerze produktów pod nazwą 
subset_X_of_Y, gdzie X to numer podzbioru, Y to nazwa danych, z których pochodzi podzbiór. Dane 
przechowywane są w pamięci podręcznej i należy je zapisać na dysk lokalny do folderu ćwiczeniowego. 
Produkty zapisuje się klikając prawym przyciskiem na nazwę nowostworzonego produktu 
(subset_X_of_XXXXXXX) i wybierając polecenie Save Product As. 
Powtórz czynność dla następnych zbiorów danych. Do celów ćwiczenia pliki zapisz w formacie BEAM-
DIMAP z rozszerzeniem *.dim o nazwie w konwencji NazwaObiektu_DataRejestracji czyli: 
Yorkshire_20191105, Yorkshire_20191111, Yorkshire_20191117. 
Po zapisaniu plików zaleca się zamknięcie wszystkich produktów w programie, a następnie otworzenie 
plików ponownie ostatnio zapisanych plików. 
Produkty zamyka się wybierając w głównym pasku narzędzi File > Close Product. 

Produkty wczytaj wybierając w głównym pasku narzędzi File > Open Product pliki z rozszerzeniem 
*.dim: Yorkshire_20191105.dim, Yorkshire_20191111.dim, Yorkshire_20191117.dim 

 
3. Uaktualnienie danych orbitalnych 

Do aktualizacji danych orbitalnych mających na celu poprawienie geometrii obrazów niezbędne jest 
podłączenie do sieci internetowej. Program automatycznie pobierze odpowiednie pliki do aktualizacji 
danych orbitalnych. 
W głównym pasku narzędzi wybierz Radar > Apply Orbit File. 
W zakładce I/O Parameters w polu Source Product wskaż pojedynczo otwarte w programie dane.  
Dla każdej rejestracji określ nazwę pliku wynikowego, stosując nazwę: 
NazwaObiektu_DataRejestracji_Obr np. Yorkshire_20191105_Orb oraz wskaż format Save As: 
BEAM-DIMAP i miejsce zapisu na dysku (MD_3_2\Wyniki).   
W zakładce Processing Parameters w polu Orbit State Vector wskaż typ danych orbitalnych 
wybierając orbity precyzyjne: Sentinel Precise (Auto Download) oraz rekomendowany stopień  
wielomianu Polynomial Degree: 3. 
Po ustawieniu parametrów procesu kliknij Run.  
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4. Usuwanie addytywnego szumu termicznego  

Na wielu obrazach GRD można zauważyć obecność addytywnego szumu termicznego, szczególnie 
w obszarach o niskim rozproszeniu wstecznym (takich jak spokojne morze, jeziora itp.). Szum termiczny 
wynika z techniki obrazowania progresywnym skanerem TOPSAR (Terrain Observation with 
Progressive Scans SAR) i jest ledwo zauważalny, ale staje się istotny wtedy, gdy średnia sygnału jest 
niska. 
W celu usunięcia addytywnego szumu termicznego występującego na obrazach intensywności, 
szczególnie w polaryzacji krzyżowej, użyj funkcji z głównego menu Radar > Radiometric > S1 Thermal 
Noise Removal niezależnie dla każdej rejestracji. 
W zakładce I/O Parameters w polu Source Product wskaż pojedynczo dane 
NazwaObiektu_DataRejestracji_Orb.  
Dla każdej rejestracji określ nazwę pliku wynikowego, stosując nazwę: 
NazwaObiektu_DataRejestracji_Obr_TNR np. Yorkshire_20191105_Orb_TNR oraz wskaż format Save 
As: BEAM-DIMAP i miejsce zapisu na dysku (MD_3_2\Wyniki).   
W zakładce Processing Parameters w polu Polarisations wskaż polaryzację VH i zaznacz opcję 
usunięcia szumu termicznego: Remove Thermal Noise. 
Po ustawieniu parametrów procesu kliknij Run. 
Powtórz dla pozostałych rejestracji.  
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5. Kalibracja radiometryczna 

Obraz radarowy jest rozkładem stosunku energii sygnału wysłanego do energii odbitej (echa 
radarowego). Stosunek ten nazywany jest współczynnikiem rozpraszania wstecznego (ang. 
backscattering coefficient) i podlega procesowi kalibracji tzw. kalibracji radiometrycznej. 
Przeprowadzenie kalibracji radiometrycznej eliminuje czynniki związane z geometrią obrazowania 
i umożliwia m.in porównanie danych radarowych pochodzących z różnych sensorów, rejestrowanych 
w różnych trybach obrazowania, w różnym czasie i generowanych przez różne procesory.  
Współczynnik rozpraszania wstecznego może być wyrażany za pomocą Beta Nought, Sigma Nought 
i Gamma Nought. Najczęściej stosuje się Sigma Nought. 

Kalibrację radiometryczną danych w postaci amplitudy do postaci Sigma Nought wykonaj niezależnie 
dla każdej rejestracji korzystając z narzędzia Radar > Radiometic > Calibrate. 
W zakładce I/O Parameters w polu Source Product wskaż pojedynczo dane 
NazwaObiektu_DataRejestracji_Orb_TNR.  
Dla każdej rejestracji określ nazwę pliku wynikowego, stosując nazwę: 
NazwaObiektu_DataRejestracji_Obr_TNR_Cal np. Yorkshire_20191105_Orb_TNR_Cal oraz wskaż 
format Save As: BEAM-DIMAP i miejsce zapisu na dysku (MD_3_2\Wyniki).   
W zakładce Processing Parameters w polu Polarisations wskaż polaryzację VH i zaznacz opcję 
generowania obrazu wstecznego współczynnika rozpraszania w postaci Sigma Nought: Output 
sigma0 band. 
Po ustawieniu parametrów procesu kliknij Run.  
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6. Korejestracja 

Kluczowym elementem w analizach zbiorów wieloczasowych jest dokładne dopasowanie 
geometryczne obrazów tzw. korejestracja. Korejestracja wykonywana jest w oparciu o dane orbitalne 
i wartości pikseli. W celu osiągnięcia wysokiej dokładności korejestracji zaleca się dodatkowo 
wykorzystanie Numerycznego Modelu Terenu. 
W celu wykonania korejestracji wybierz z narzędzi Radar > Coregistration > DEM-Assisted 
Coregistration > DEM Assisted Coregistration with xCorr 
W zakładce ProdutSet-Reader za pomocą ikony plusa dodaj do listy produkty, które mają zostać 
poddane korejestracji tzn. pliki o nazwie NazwaObiektu_DataRejestracji_Orb_TNR_Cal powstałe 
w wyniku przeprowadzonej wcześniej kalibracji radiometrycznej. 
Pierwsza rejestracja na liście oznacza obraz referencyjny tzw. master, do którego zostaną 
korejestrowane pozostałe obrazy tzw. slaves. Kolejność plików na liście można zmieniać poprzez użycie 
ikon strzałek skierowanych w górę lub w dół. 
W zakładce DEM-Assisted-Coregistration wskaż NMT Digital Elevation Model: SRTM 3Sec (Auto 
Download), określić metodę przepróbkowania NMT DEM Resampling Method: 
Bilinear_Interpolation, metodę przepróbkowania obrazów Resampling Type: Bilinear_Interpolation 
i pokrycie obrazu przez NMT Tile Extension [%]: 100, a także odznaczyć opcje maskowania pikseli, dla 
których nie ma wartości w NMT Mask out areas with no elevation. 
W zakładce Cross-Corelation określ liczbę punktów GCP na podstawie, których zostanie wykonana 
korejestracja Number of GCPs: 200. 
W zakładce Warp określ dokładność wykonanej korekcji geometrycznej RMS Threshold [pixel 
accuracy]: 1, stopień wielomianu Warp polynomial Order: 1 oraz metodę interpolacji Interpolation 
Method: Bilinear interpolation. 
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Próg RMS eliminuje nieprawidłowe punkty GCP.  Zasadniczo im mniejszy próg, tym lepsza jakość 
punktów GCP, ale również ich mniejsza liczba. W przypadku obrazów pochodzących z tej samej orbity 
i o identycznych parametrach rejestracji, a także po uaktualnieniu danych orbitalnych próg RMS 
wynoszący 1 piksel jest najlepszą możliwą opcją. Z tych samych względów wielomian pierwszego 
stopnia jest wystarczający do osiągnięcia oczekiwanych dokładności korejestracji.  

 
W zakładce Write określ nazwę pliku wynikowego, stosując nazwę: NazwaObiektu_Stack_Sigma0 
czyli Yorkshire_Stack_Sigma0 oraz wskaż format Save As: BEAM-DIMAP i miejsce zapisu na dysku 
(MD_3_2\Wyniki). Po ustawieniu parametrów kliknij Run. 
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7. Filtracja efektu plamkowania 

Obrazowanie radarowe charakteryzuje się dużą zmiennością wartości sąsiadujących pikseli. Jest to tak 
zwany efekt plamkowania (ang. speckle effect), potocznie nazywany również efektem soli i pieprzu. 
W celu zredukowania efektu plamkowania wykonuje się filtrację obrazów. Filtracje mogą opierać się 
na różnych rozkładach np. normalnym (Gaussa) lub gamma. Wśród prostych metod filtracji wyróżnia 
się filtry oparte na średniej arytmetycznej (Boxcar) i medianie (Median). Do bardziej złożonych metod 
stosowanych do danych radarowych zalicza się metody takie jak Lee, Frost, IDAN, Gamma-MAP. 
Niestety nie istnieje idealny filtr, który spowodowałby wygładzenie obszarów homogenicznych przy 
zachowaniu pełnej szczegółowości i rozdzielczości. Wybór metody filtracji zależy całkowicie od 
użytkownika. Na potrzeby niniejszego zadania została wybrana metoda filtracji Lee Sigma. Filtr ten jest 
oparty na modelu rozkładu Gaussa i uśrednia tylko piksele w określonym zakresie odchyleń 
standardowych. 
W głównym pasku narzędzi wybierz Radar > Speckle Filtering > Single Product Speckle Filter. 
W zakładce I/O Parameters w polu Source Product wskaż dane korejestrowane 
Yorkshire_Stack_Sigma0 w polu Target Product określ nazwę pliku wynikowego, stosując nazwę: 
NazwaObiektu_Stack_Sigma0, czyli Yorkshire_Stack_sigma0_Spk oraz wskaż format Save As: BEAM-
DIMAP i miejsce zapisu na dysku (MD_3_2\Wyniki).   

W zakładce Processing Parameters w polu Source Band wskaż wszystkie kanały polaryzacji i wybierz 
metodę filtracji Filter: Lee Sigma. Po ustawieniu parametrów kliknij Run. 

mailto:michal.pilecki@polsa.gov.pl


                                                                                               

14 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

 

 
 
8. Konwersja danych do skali logarytmicznej (dB) 

Konwersję danych ze skali liniowej na skalę logarytmiczną (dB) wykonaj stosując funkcję Raster > Data 
Conversion > Converts bands to/from dB dla wszystkich obrazów Sigma0. 
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9. Geokodowanie – transformacja obrazu do układu kartograficznego 

Transformację do układu kartograficznego wykonaj stosując narzędzie Radar > Geometric > Terrain 
Correction > Range-Doppler Terrain Correction. 
W zakładce I/O Parameters w polu Source Product wskaż dane po przeprowadzonej filtracji 
Yorkshire_Stack_Sigma0_Spk_dB w polu Target Product określ nazwę pliku wynikowego, stosując 
nazwę: NazwaObiektu_Stack_Sigma0_Spk_dB_TC czyli Yorkshire_Stack_Sigma0_Spk_dB_TC oraz 
wskaż format Save As: BEAM-DIMAP i miejsce zapisu na dysku (MD_3_2\Wyniki).  
W zakładce Processing Parameters w polu Source Band wskaż wszystkie obrazy Sigma0, w polu 
numerycznego modelu terenu Digital Elevation Model wskaż: SRTM 3Sec (Auto Download). Jako 
metodę przepróbkowania DEM DEM resampling method wybierz: Bilinear Interpolation, tak samo jak 
w przypadku metody przepróbkowania obrazów transformowanych Image Resampling Method. 
Wymiar piksela docelowego Pixel spacing to 10 m w układzie współrzędnych geograficznych Map 
projection: WGS84(DD). Dodatkowo odznacz Mask out areas with no elevation. Po ustawieniu 
parametrów kliknij Run. 

 

…\MD_3_2\Przetwarzanie 
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10. Wizualizacja kompozycji kolorowej 

W Product Explorer kliknij na nazwę ostatnio wygenerowanego produktu 
Yorkshire_Stack_Sigma0_Spk_dB_TC, a następnie w menu głównym wybierz Window > Open RGB 
Image Window. Jako składowe RGB wczytaj:  
RED: Sigma0_VH_slv1_17Nov2019_dB,  
GREEN: Sigma0_VH_slv1_11Nov2019_dB,  
BLUE: Sigma0_VH_mst_5Nov2019_dB. 

 

MD_3_2\Wyniki 
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W celu poprawy wizualizacji otrzymanej kompozycji kolorowej w oknie Colour manipulation 
niezależnie dla każdego z kanałów rozciągnij kontrast liniowo stosując zakres 95%. Oznacza to, że 
2.5% pikseli o najmniejszych wartościach przyjmie jedną wartość (wartość minimalną) i 2.5% pikseli 
o wartościach największych przyjmie jedną wartość (wartość maksymalną). 

 
Stworzona w ten sposób kolorowa kompozycja pokazuje obszary powodziowe.  

Kolorem czarnym pokazane są obiekty charakteryzujące się niskim odbiciem na każdym z obrazów 
(a więc na każdej z dat), są to stałe zbiorniki wodne. 
Kolorem niebieskim pokazane są obszary powodziowe, na których w badanym okresie woda najdłużej 
stagnowała. W tym przypadku powierzchnia wody została wykryta na obu rejestracjach z 11 i 17 
listopada. 
Kolorem cyjanowym pokazane są obszary powodziowe wykryte tylko 17 listopada 
W kolorze magenta pokazane są obszary powodziowe wykryte tylko 11 listopada. 
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11. Binaryzacja 

Jednym ze sposobów odseparowania obszarów powodziowych od pozostałych obszarów jest 
progowanie. Można założyć, że niskie wartości rozpraszania wstecznego odpowiadają gładkim 
i płaskim powierzchniom, do których bez wątpienia można zaliczyć powierzchnię wody, a wysokie 
wartości odpowiadają pozostałym obszarom. Najtrudniejszym zadaniem w tym kroku jest określenie 
wartości progu, które ułatwi wykonanie analizy statystycznej wartości pikseli dla przykładowej 
powierzchni wody. 
Do określenia wartości progu rozdzielającego dwie klasy zostanie wykorzystany wcześniej 
przygotowany poligon testowy w formacie *.shp o nazwie Water_ROI_Polygon_Polygon. 
W Product Explorer zaznacz nazwę produktu Yorkshire_Stack_Sigma0_Spk_dB_TC, w menu 
głównym wybierz Vector > Import > ESRI Shapefile, a następnie wskaż plik 
Water_ROI_Polygon_Polygon. Na obrazie zostanie wyświetlony poligon testowy, który na każdym 
obrazie jest powierzchnią wody. 

 
 

W celu przeprowadzenia analizy wartości pikseli dla obszaru testowego w oknie Product Explorer po 
rozwinięciu produktu Yorkshire_Stack_Sigma0_Spk_dB_TC zaznacz kanał (band) 
Sigma0_VH_mst_05Nov2019, a następnie z głównego menu wybierz Analysis > Statistics. 

W nowo otwartym oknie zaznacz Use ROI Mask i Water_ROI_Polygon i kliknij w ikonę odświeżania 
Refresh. Czynność powtórz dla pozostałych kanałów: Sigma0_VH_slv1_11Nov2019 
i Sigma0_VH_slv1_17Nov2019 
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Statystyki wartości pikseli w obszarze poligonu dla obrazu z 5 listopada 2019

 
Statystyki wartości pikseli w obszarze poligonu dla obrazu z 11 listopada 2019 

 
Statystyki wartości pikseli w obszarze poligonu dla obrazu z 17 listopada 2019 

 

Wartością progową może być wartość maksymalna lub percentyl bliski 100% w obszarze testowym. 
Na przykład percentyl 99% uwzględnia niewielką niedoskonałość obszaru testowego. Należy jednak 
pamiętać, że wartości te mogą różnić się w zależności od wielkości i od położenia poligonu testowego. 
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Z analizy statystycznej wynika, że maksymalna wartość pikseli reprezentujących powierzchnię wody 
wynosi: -23.4907 dla obrazu z 5 listopada, -25.1220 dla obrazu z 11 listopada, -24.4957 dla obrazu 
z 17 listopada. Na potrzeby niniejszego ćwiczenia wartościami progowymi będą zaokrąglone wartości 
maksymalne. 
W celu wybrania pikseli nieprzekraczających wartości progowej stworzony zostanie obraz, gdzie 
wartość 1 będzie oznaczała powierzchnię wody, a 0 będzie reprezentowało pozostałe obszary.  

Z głównego menu wybierz Raster > Band Maths. W oknie Band Maths wybierz produkt, w którym 
zostanie stworzony nowy obraz Target Product, czyli Yorkshire_Stack_Sigma0_Spk_dB_TC oraz 
określ nazwę tworzonego obrazu Name Water_Mask_11Nov. Dodatkowo odznacz opcję tworzenia 
pliku wirtualnego, niezapisywanego na dysku Virtual. Następnie kliknij na przycisk Edit Expression 
w celu zastosowania wartości progowej/określenia formuły. W polu Expression wpisz formułę: 

if Sigma0_VH_slv1_11Nov2019_db < -25 and Sigma0_VH_mst_05Nov2019_db > -23.5 then 
1 else NaN 

Jeżeli program nie znajdzie błędu zostanie wyświetlony komunikat: Ok, no errors. Po czym kliknij OK 
i następnie też OK. 
Czynność tworzenia nowego obrazu wykonaj ponownie dla obrazów z dnia 17 listopada i z 5 listopada 
stosując następujące formuły: 

Dla 17 listopada: 

if Sigma0_VH_slv1_17Nov2019_db < -24.5 and Sigma0_VH_mst_05Nov2019_db > -23.5 then 
1 else NaN 

Dla 5 listopada: 
if Sigma0_VH_mst_05Nov2019_db < -23.5 then 1 else NaN 
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12. Wizualizacja wyników w Google Earth 

Warstwy wektorowe można wyeksportować z programu SNAP również do formatu Shapefile 
i zwizualizować w dowolnym programie GIS (np. QGIS). 

W celu wizualizacji wyników w Google Earth wyeksportuj wyniki do formatu *.kmz. W pierwszej 
kolejności wyświetl kanały Water_Mask_5Nov, Water_Mask_11Nov, Water_Mask_17Nov. Kliknij 
dwukrotnie na nazwę kanału (Bands) w danym produkcie z listy w menadżerze produktów Product 
Explorer. Wyświetlając każdy z obrazów wybierz z menu głównego File > Export > Other > View As 
Google Earth KMZ i zapisz pliki na dysku. 
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Następnie otwórz zapisane pliki w programie Google Earth, klikając na nie dwukrotnie.  

 
Wyświetlone wyniki pokazują: 
Water_mask_5Nov –  stan wody sprzed powodzi, czyli stałe wody powierzchniowe na dzień 
5 listopada 2019 
Water_mask_11Nov – powierzchnie powodziowe na dzień 11 listopada 2019 bez stałych wód 
powierzchniowych 
Water_mask_17Nov – powierzchnie powodziowe na dzień 17 listopada 2019 bez stałych wód 
powierzchniowych  

Zaprezentowane ćwiczenie pokazuje możliwość wykorzystania danych radarowych do monitorowania 
powierzchni obszarów zalewowych. Co więcej wykorzystanie danych satelitarnych umożliwia 
wielkoobszarowe analizy w niedługim czasie po wystąpieniu powodzi, a nawet w czasie prawie 
rzeczywistym.  
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