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Opis zadania  

W skutek nawałnic, które w nocy z 11 na 12 sierpnia 2017 r. spustoszyły lasy kilkudziesięciu 
nadleśnictw w północnej Polsce zniszczeniu uległo niemal 120 tys. ha lasów. W przypadku tego 
rodzaju zjawisk ekstremalnych bardzo ważne jest szybkie dostarczenie informacji o zasięgu uszkodzeń. 
Pomaga to w oszacowaniu szkód w wymiarze miąższościowym i odpowiednim zaplanowaniu prac 
leśnych. Zadanie polega na określeniu wielkości szkód pohuraganowych. Zadanie opiera się na 
porównaniu dwóch zobrazowań satelitarnych Sentinel-1 po wcześniejszym ich przetworzeniu. 
Zobrazowania pochodzą sprzed i po wystąpieniu huraganu. 

Cel zadania 

• analiza zobrazowań radarowych dla drzewostanów w okresie przed oraz po wystąpieniu 
uszkodzeń pohuraganowych 

• obliczenie powierzchni szkód dla wybranego obszaru. 

Wykaz danych przestrzennych GIS 

• zobrazowania satelitarne satelity Sentinel-1 (Level-1 GRD) pozyskane w dniach:  
02.08.2017: 
S1A_IW_GRDH_1SDV_20170802T163555_20170802T163620_017747_01DBA1_C11D.SAFE 
14.08.2017: 
S1A_IW_GRDH_1SDV_20170814T163556_20170814T163621_017922_01E0F5_6F67.SAFE 
 

• plik zawierający granice wydzieleń Nadleśnictwa Rytel oraz Czersk (BDL): LMN.shp 

• zobrazowanie satelitarne satelity Sentinel-2 (L2A) pozyskane w dniu 29.09.2017: 
20170928_S2.tif 

Wykaz stron internetowych 

• Pobieranie zobrazowań satelitarnych Sentinel-2:  
https://scihub.copernicus.eu/dhus/#/home 

Wykaz zastosowanego oprogramowania 

• SNAP 8.0 
• QGIS 3.16 
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Opis ćwiczenia  
1. Wczytanie zobrazowań satelitarnych do programu SNAP 

Interfejs programu składa się z kilku elementów, z których zasadniczą część stanowi okno wyświetlania 
danych (2) oraz okno, w którym wyświetlana jest lista zobrazowań wczytanych do projektu (1). 
W górnym pasku (3) widoczne są narzędzia z aktualnie włączonych pasków narzędziowych. 

 

W celu dodania zobrazowań satelitarnych do programu SNAP wybierz opcję File > Open Product 
 a następnie wskaż plik manifest.safe, znajdujący się w folderze z zobrazowaniem 

satelitarnym.  
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Lista wczytanych zobrazowań pojawia się w oknie Product Explorer. 

 
W sytuacji, gdy okno Product Explorer zostanie przypadkowo zamknięte, możne je ponownie otworzyć 
korzystając z opcji View > Tool Windows > Product Explorer. 

W ćwiczeniu wyświetl obrazy Amplitude_VH oraz Amplitude_VV dla każdej importowanej rejestracji. 

 

2. Wstępna obróbka i przygotowanie zobrazowań 

Na proces przygotowania zobrazowań Sentinel 1 będzie się składać z następujących etapów:  

• ograniczenie zasięgu zobrazowań do wybranego obszaru, 
• uaktualnienie danych orbitalnych, 
• usuwanie addytywnego szumu termicznego, 
• kalibracja radiometryczna, 
• filtracja efektu plamkowania, 
• konwersja danych do formatu ośmiobitowego (int8), 
• geokodowanie – transformacja obrazu do układu kartograficznego. 

Każdy z wymienionych etapów może być wykonany pojedynczo lub za pomocą narzędzia Graph 
Builder,  w którym możliwe jest stworzenie modelu (przepływu pracy), który łączy ze sobą sekwencje 
narzędzi geoprzetwarzania, przekazując dane wyjściowe jednego narzędzia do innego narzędzia jako 
dane wejściowe. To podejście jest przydatne szczególnie wtedy, gdy potrzebujemy w ten sam sposób 
przetworzyć zobrazowania z kilku terminów, co pozwoli zaoszczędzić czas oraz gdy nie potrzebne są 
wyniki przetworzeń poszczególnych narzędzi, a jedynie efekt końcowy, co z kolei pozwoli zaoszczędzić 
miejsce na dysku.  

Poszczególne etapy wymienionych powyżej przetworzeń są szczegółowo opisane w scenariuszu 
warsztatowym 3 z zakresu leśnictwa (OZ-4) „Analiza skutków klęski żywiołowej”. Poniżej zostanie 
zaprezentowany sposób budowy modelu składającego się z wymienionych etapów. 
 
W oknie Product Explorer powinny się znajdować obydwa zobrazowania Sentinel 1, następnie 
z zakładki wybieramy Tools > Graph Builder. 
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Przejdź do zakładki Read i wskaż jedno ze zobrazowań, następnie w polu z narzędziami kliknij PPM 
i wybierz Add > Raster > Subset (za pomocą tego narzędzia zostanie ograniczony zasięg zobrazowania 
do wybranego obszaru): 

 
 

Połącz kafelek Read z Subset zaczynając od najechania kursorem na prawą krawędź kafelka Read. 

 
W parametrach tego narzędzia zaznacz warstwy z amplitudą Amplitude_VV i Amplitude_VH.  
Za X: wstaw 12300, a Y: 7000. Za Width: 4700, a height: 2600. 
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W kolejnym kroku wyszukaj Radar > Aplly orbit file i połącz Subset z Aplly orbit file (to narzędzie 
spowoduje uaktualnienie danych orbitalnych). Tutaj parametry pozostaw bez zmian. Następnie 
odszukaj i wybierz Radar > Radiometric > ThermalNoiseRemoval i wykonaj połączenie Apply orbit 
file z ThermalNoiseRemoval (za pomocą tego narzędzia zostanie usunięte addytywny szum 
termiczny). Kolejne narzędzie to Radar > Radiometric > Calibration,  służące do kalibracji 
radiometrycznej. Połącz je z poprzednim narzędziem, a w jego parametrach wskaż polaryzację VV oraz 
VH. Kolejne narzędzie to Radar > Speckle Filtering > Speckle Filter (filtracja efektu plamkowania), 
także go połącz z poprzednim narzędziem i znów wskaż obydwie polaryzacje i zmień parametr 
Window size: 11x11. Następnie wybierz Raster > Data conversion > Convert Datatype (konwersja 
danych do formatu ośmiobitowego (int8)) i połącz ze Speckle Filter. Ostatnie narzędzie to Radar > 
Geometric > Terrain Correction > Terrain Correction, które wykonuje transformację obrazu do układu 
kartograficznego. Wykonaj połączenie z narzędziem Convert Datatype i zmień Map projection na 
UTM/WGS 84 (Automatic) oraz odznacz opcję Mask out areas without elevation. Połącz narzędzie 
Terrain Correction także z kafelkiem Write, w którym wskaż nazwę oraz ścieżkę zapisu pliku 
wynikowego.  

mailto:michal.pilecki@polsa.gov.pl
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Następnie kliknij Save i wskaż miejsce zapisu oraz nazwę powstałego modelu. Aby uruchomić 
wszystkie procesy zapisane w modelu kliknij Run i czynność powtórz dla drugiego zobrazowania 
zmieniając parametry w zakładce Read i Write. 
 
3. Korejestracja 

Kluczowym elementem w analizach zbiorów wieloczasowych jest dokładne dopasowanie 
geometryczne obrazów tzw. korejestracja. Korejestracja wykonywana jest w oparciu o dane orbitalne 
i wartości pikseli.  

Przed przystąpieniem do wykonania korejestracji wyświetl kanał z polaryzacją VV razem dla dwóch 
terminów i spróbuj zlokalizować obszar dotknięty klęską żywiołową. Następnie czynność tę powtórz 
dla polaryzacji VH i oceń, która polaryzacja będzie lepsza do wyznaczenia wielkości szkód. 

mailto:michal.pilecki@polsa.gov.pl
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W celu wykonania korejestracji wybierz z narzędzi Radar > Coregistration > Coregistration. 
W zakładce ProductSet-Reader za pomocą ikony plusa dodaj do listy produkty, które mają zostać 
poddane korejestracji. Pierwsza rejestracja na liście oznacza obraz referencyjny tzw. master, do którego 
zostaną korejestrowane pozostałe obrazy tzw. slaves. Kolejność plików na liście można zmieniać 
poprzez użycie ikon strzałek skierowanych w górę lub w dół, a same pliki wejściowe dodajemy poprzez 
ikonę plusa. W zakładce CreateStack, Cross-Correlation i Warp pozostaw domyślne ustawienia 
narzędzia.  
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4. Przycięcie zobrazowania do maski lasu 

Aby załadować dane wektorowe z maską lasu należy zaznaczyć przycinany obraz klikając na niego 
lewym przyciskiem myszy i wejść w zakładkę Vector > Import > ESRI Shapefile, w menu głównym. 

 
Wskazujemy plik LMN.shp. Po zatwierdzeniu pojawi się komunikat z zapytaniem czy każdy poligon ma 
być wczytany jako osobna warstwa, wskazujemy odpowiedź No. 

 
Po rozwinięciu produktu w okienku Product explorer nowa warstwa pojawi się w zakładce Vector 
Data. 

Przycięcie zobrazowania warstwą wektorową jest możliwe w zakładce Raster > Masks > Land/Sea 
Mask. W opcjach I/O Parameters wybieramy odpowiedni produkt  i ścieżkę oraz nazwę zapisu pliku 
wynikowego. W Processing Parameters wybieramy kanały, na których ma zostać wykonana maska 
(zaznaczyć wszystkie kanały) oraz opcję Use Vector Mask. Pojawia się opcja wyboru odpowiedniego 
shapefile z maską. Wymaskowany obraz powinien posiadać tylko informację o obszarach leśnych, 
reszta obrazu powinna przechowywać informację No Data. 
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11 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

 
 

5. Wyświetlenie kompozycji barwnej 

W Product Explorer kliknij na nazwę przyciętego do granic lasu zobrazowania, a następnie w menu 
głównym wybierz Window > Open RGB Image Window. Jako składowe RGB wczytaj:  
RED: Sigma0_VV_slv2_14Aug2017,  
GREEN: Sigma0_VV_mst_02Aug2017,  
BLUE: Sigma0_VV_mst_02Aug2017. 

 
Aby wyłączyć wyświetlanie warstwy wektorowej należy przejść do Layer Manager i odznaczyć Vector 
data: 

 
Dzięki takiemu ustawieniu kanałów w kompozycji barwnej kolorem czerwonym zostaną przedstawione 
obszary, które uległy zniszczeniu podczas huraganu: 
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6. Klasyfikacja nienadzorowana 

Wyznaczenie powierzchni uszkodzonych drzewostanów może odbywać się na kilka sposobów. 
Podczas niniejszego ćwiczenia zostanie zaprezentowana metoda klasyfikacji nienadzorowanej. 
W zakładce Raster > Classification wybieramy klasyfikację nienadzorowaną (Unsupervised 
Classification), czyli taką, gdzie wskazujemy tylko na ile klas ma zostać podzielony dany obszar. 
Zostanie wykorzystany algorytm K-Means Cluster Analysis. 

 
 

W zakładce I/O Parameters wskazujemy plik źródłowy, nazwę oraz miejsce zapisu pliku wynikowego, 
a także zmieniamy format zapisu na GeoTIFF. W kolejnej zakładce: Processing Parameters zmieniamy 
parametr Number of Clusters: 4, a w Source band names zaznaczamy tylko kanały z polaryzacją 
wertykalną:  Sigma0_VV_mst_02Aug2017, Sigma0_VV_slv2_14Aug2017. 

 
 
Zadaniem użytkownika jest zinterpretowanie powstałych klas. Aby wyświetlić wynik klasyfikacji 
rozwiń nowo powstały produkt w okienku Product Explorer, następnie Bands i dwukrotnie kliknij LPM 
na class_indices. Odnajdź klasę z uszkodzonymi drzewostanami i w okienku Color Manipulation zmień 
barwę klasy na czerwoną, a pozostałym klasom nadaj białą barwę. 

mailto:michal.pilecki@polsa.gov.pl
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7. Wyświetlenie wyniku w programie QGIS 

Otwórz program QGIS, wczytaj przycięte zobrazowanie Sentinel 2 z 29.08.2017 r. i wzmocnij kontrast 
do pełnego zakresu danych: 
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Następnie wczytaj wynik klasyfikacji nienadzorowanej i zmień sposób wyświetlania, tak aby widoczna 
była tylko klasa z uszkodzonymi drzewostanami. Aby to zrobić przejdź do jej Właściwości > Styl, 
następnie kliknij przycisk Klasyfikuj, z naciśniętym przyciskiem Ctrl zaznacz wszystkie klasy poza tą 
z uszkodzonymi drzewostanami i kliknij Usuń zaznaczone wiersze, na końcu zmień kolor 
pozostawionej klasy na czerwony i zatwierdź zmiany przyciskiem OK. 

 
Mapa uszkodzonych drzewostanów: 
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8. Obliczenie powierzchni uszkodzonych drzewostanów 

W celu określenia powierzchni uszkodzonych drzewostanów wybierz zakładkę Processing i pole Panel 
algorytmów. W ten sposób w prawej części ekranu otworzona zostanie zakładka Algorytmy 
Processingu następnie z zakładki Raster – analiza wybierz pole Raport unikalnych wartości rastra. 
W nowo otwartym oknie w zakładce Warstwa źródłowa wybierz warstwę z wynikiem klasyfikacji, 
a następnie w zakładce Raport unikalnych wartości wybierz pole (...), a następnie z menu podręcznego 
wybierz pole Zapisz do pliku.... Następnie w oknie Zapisz plik wskaż nazwę pliku i miejsce zapisu 
(zalecany wybór folderu to MD_3_4/Wyniki) oraz wybierz pole Zapisz. Na koniec kliknij pole Uruchom. 
Aby zobaczyć Raport unikalnych wyników otwórz nowo powstały plik. 
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Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

 
 

Zaletą danych radarowych jest to, że są generowane na podstawie fal radiowych, których długość 
zapewnia brak wrażliwości na warunki atmosferyczne (np. zachmurzenie) w przeciwieństwie do 
danych optycznych, które z kolei posiadają większą szczegółowość obrazu przy takiej samej 
rozdzielczości przestrzennej, przez co dają dokładniejszy wynik w przypadku określania szkód 
pohuraganowych. Zarówno Sentinel-1 oraz Sentinel-2 posiadają podobną rozdzielczość czasową, 
jednak dane optyczne nie zawsze nadają się do analiz i w przypadku potrzeby szybkiej informacji 
pomocne są dane radarowe, które mogą wstępnie wskazać powierzchnie wyrządzonych szkód, co 
z kolei może być pomocne przy planowaniu nalotów fotogrametrycznych, które są kosztowne, 
a informacja o potencjalnym  zasięgu szkód pozwoli zminimalizować koszty. 
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