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Opis zadania  

W pierwszej części warsztatu przeanalizowane zostanie zobrazowanie radarowe Sentinel-1 okolic 
Tarnowa, na podstawie którego dokonana zostanie detekcja obszarów zabudowanych. W tym celu 
niezbędne jest wstępne przygotowanie danych poprzez usunięcie szumów oraz zniekształceń 
geometrycznych, a także dokonanie analizy tekstury obrazu w celu określenia obszarów 
o odpowiednim współczynniku rozproszenia plamkowego. Przeprowadzona w ten sposób analiza 
sygnału pozwoli na wyodrębnienie obszarów zabudowanych w Tarnowie. W drugiej części warsztatu 
do detekcji budynków zostanie wykorzystane wysokiej rozdzielczości zobrazowanie radarowe Capella 
fragmentu Warszawa. W tym celu niezbędne jest dokonanie analizy tekstury obrazu w celu określenia 
obszarów o odpowiednim współczynniku rozproszenia plamkowego. Zaimportowany produkt został 
już wstępnie przetworzony oraz ma nadaną referencję, stąd możliwe jest pominięcie części 
preprocessingu. Przeprowadzona w ten sposób analiza sygnału pozwoli na wyodrębnienie obszarów 
zabudowanych dla części Warszawy. 

Cel zadania 

• określenie położenia obszarów zabudowanych dla wybranego rejonu. 

Wykaz danych przestrzennych GIS 

• zobrazowanie satelitarne satelity Sentinel-1 (Level-1 GRD) pozyskane w dniu:  
13.03.2022: 
S1A_IW_GRDH_1SDV_20220313T045327_20220313T045352_042298_050AB5_0155.zip 

• wysokorozdzielcze zobrazowanie satelitarne pochodzące z jednego z satelitów konstelacji 
Capella (produkt GEO) pozyskane w dniu:  
02.04.2021:  
CAPELLA_C03_SP_GEO_HH_20210402194742_20210402194803 

• zobrazowanie satelitarne satelity Sentinel-2 pozyskane w dniu: 
20.03.2022:  
S2_20220320.tif 

Wykaz stron internetowych 

• Pobieranie zobrazowań satelitarnych Sentinel-1/2:  
https://scihub.copernicus.eu/dhus/#/home 

Wykaz zastosowanego oprogramowania 

• SNAP 8.0 
• QGIS 3.16 
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Opis ćwiczenia – cz.1 detekcja obszarów zabudowanych na obrazie Sentinel-1  

1. Wczytanie zobrazowań satelitarnych do programu SNAP 

W celu dodania zobrazowania do programu SNAP wybierz opcję File > Open Product, a następnie 
wskaż plik w formacie katalogu ZIP, znajdujący się w folderze z zobrazowaniami satelitarnymi. Dane 
można dodać również poprzez przeciągnięcie plików do okna Product Explorer. 

 
Wczytane zobrazowanie pojawia się w oknie Product Explorer. 

Zaimportowane dane to produkt Ground Range Detected (GRD) pochodzący z satelity Sentinel-1. Po 
rozwinięciu danych o produkcie, rozwiń dodatkowo zakładkę Bands. Znajdują się tam obrazy amplitudy 
oraz intensywności odbicia wiązki radarowej dla dwóch polaryzacji: VH oraz VV. W celu wyświetlenia 
obrazu, kliknij dwukrotnie na wybraną warstwę. Poniżej przedstawiono podgląd warstwy 
Amplitude_VV. 
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Przykładowy obraz amplitudy: 

 
 

2. Ograniczenie zasięgu zobrazowań satelitarnych do obszaru opracowania 

Każdy produkt Sentinel-1 obejmuje swoim zasięgiem znaczną powierzchnię. W celu usprawnienia 
pracy na danych, obszar opracowanie zostanie ograniczone tylko do okolic miasta Krakowa. 

W celu przycięcia zobrazowania wybierz opcję Raster > Subset lub na wyświetlonym zdjęciu kliknij 
prawy przycisk myszy i wybierz Spatial Subset form View. W oknie narzędzia Subset wybierz 
zakładkę Spatial Subset i zdefiniuj współrzędne prostokąta, który zostanie wykorzystany do 
ograniczenia zasięgu zobrazowania przechodząc do zakładki Geo Coordinates: 

Nort latitude bound: 50.07 
West longitude bound: 21.21 
South latitude bound: 49.94 
East longitude bound: 20.62 

 
W kolejnych zakładkach: Band Subset, Tie-Point Grid Subset oraz Metadata Subset pozostaw 
zaznaczoną opcję Select All.  
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Po kliknięciu OK w oknie Product Explorer zostanie utworzony nowy plik o nazwie subset_X_of_Y, 
gdzie X to numer podzbioru, Y to nazwa danych, z których pochodzi podzbiór. Dane przechowywane 
są w pamięci podręcznej i należy je zapisać na dysk lokalny do folderu ćwiczeniowego 
(MD_3_5\Wyniki). Produkty zapisuje się klikając prawym przyciskiem na nazwę nowostworzonego 
produktu (subset_X_of_XXXXXXX) i wybierając polecenie Save Product As. W celu sprawniejszej 
identyfikacji danych skróć nazwę pliku do następującej postaci: sub_20220313.dim. 

Po zapisaniu plików zaleca się zamknięcie wszystkich produktów w programie, a następnie otworzenie 
ponownie ostatnio zapisanych plików.  

Produkty zamyka się wybierając w głównym pasku narzędzi File > Close All Products bądź klikając 
prawym przyciskiem myszy w Product Explorer na dowolny produkt i wybierając opcję Close All 
Products. 
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3. Uaktualnienie danych orbitalnych 

Do aktualizacji danych orbitalnych mających na celu poprawienie geometrii obrazów niezbędne jest 
podłączenie do sieci internetowej. Program automatycznie pobierze odpowiednie pliki do aktualizacji 
danych orbitalnych. Orbity precyzyjne, zapewniające najwyższą dokładność obliczeń, udostępniane są 
po ok. 20 dniach od daty wykonania zobrazowania. 
 
W głównym pasku narzędzi wybierz Radar > Apply Orbit File.  W zakładce I/O Parameters w polu 
Source Product wskaż pierwsze z zobrazowań. Dla każdego kolejnego kroku nazwę pliku wynikowego 
pozostaw domyślną oraz wskaż format Save As: BEAM-DIMAP i miejsce zapisu na dysku 
(MD_3_5\Wyniki). W zakładce Processing Parameters w polu Orbit State Vector wskaż typ danych 
orbitalnych wybierając orbity precyzyjne: Sentinel Precise (Auto Download) oraz rekomendowany 
stopień wielomianu Polynomial Degree: 3.  Po ustawieniu parametrów procesu kliknij Run. 

 
 
4. Kalibracja radiometryczna 

Obraz radarowy jest rozkładem stosunku energii sygnału wysłanego do energii odbitej (echa 
radarowego). Stosunek ten nazywany jest współczynnikiem rozpraszania wstecznego (ang. 
backscattering coefficient) i podlega procesowi kalibracji tzw. kalibracji radiometrycznej. 
Przeprowadzenie kalibracji radiometrycznej eliminuje czynniki związane z geometrią obrazowania 
i umożliwia m.in porównanie danych radarowych pochodzących z różnych sensorów, rejestrowanych 
w różnych trybach obrazowania, w różnym czasie i generowanych przez różne procesory. 
Współczynnik rozpraszania wstecznego może być wyrażany za pomocą Beta Nought, Sigma Nought 
i Gamma Nought. 
 
W celu wykonania kalibracji radiometrycznej danych do postaci Beta Nought wybierz Radar > 
Radiometic > Calibrate. W zakładce I/O Parameters w polu Source Product produkt z rozszerzeniem 
_Orb. W zakładce Processing Parameters w polu Polarisations wskaż obie polaryzacje VH i VV, 
a następnie zaznacz opcję generowania obrazu wstecznego współczynnika rozpraszania w postaci 
Beta Nought: Output beta0 band. Po ustawieniu parametrów procesu kliknij Run. 

mailto:michal.pilecki@polsa.gov.pl
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Obraz amplitudy (lewa strona) i współczynnika rozpraszania wstecznego (prawa strona): 

 
  

mailto:michal.pilecki@polsa.gov.pl


                                                                                               

9 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

 
 

5. Filtracja efektu plamkowania 

Obrazowanie radarowe charakteryzuje się dużą zmiennością wartości sąsiadujących pikseli. Jest to tak 
zwany efekt plamkowania (ang. speckle effect), potocznie nazywany również efektem soli i pieprzu. 
W celu zredukowania efektu plamkowania wykonuje się filtrację obrazów. Filtracje mogą opierać się 
na różnych rozkładach np. normalnym (Gaussa) lub gamma. Wśród prostych metod filtracji wyróżnia 
się filtry oparte na średniej arytmetycznej (Boxcar) i medianie (Median). Do bardziej złożonych metod 
stosowanych do danych radarowych zalicza się metody takie jak Lee, Frost, IDAN, Gamma-MAP. 
Niestety nie istnieje idealny filtr, który spowodowałby wygładzenie obszarów homogenicznych przy 
zachowaniu pełnej szczegółowości i rozdzielczości. Wybór metody filtracji zależy całkowicie od 
użytkownika. Na potrzeby niniejszego zadania została wybrana metoda filtracji Lee Sigma. Filtr ten jest 
oparty na modelu rozkładu Gaussa i uśrednia tylko piksele w określonym zakresie odchyleń 
standardowych.  

W głównym pasku narzędzi wybierz Radar > Speckle Filtering > Single Product Speckle Filter. 
W zakładce I/O Parameters w polu Source Product wskaż dane po kalibracji radiometrycznej. 
W zakładce Processing Parameters w polu Source Band wskaż wszystkie kanały polaryzacji i wybierz 
metodę filtracji Filter: Lee Sigma, Windows size: 5x5, Target Window Size: 3x3 a pozostałe 
parametry pozostaw domyślne. Po ustawieniu parametrów kliknij Run. 
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Fragment analizowanego zobrazowanie przed (po lewe) i po zastosowaniu filtracji (po prawej). 
Widoczne jest zredukowanie szumów na obrazie kosztem rozdzielczości. 

 

6. Radiometryczne spłaszczenie terenu 

Z uwagi na to geometrię rejestrowania danych przez satelity z sensorami radarowymi na 
zobrazowaniach występują dystorsje geometryczne widoczne szczególnie przy nachylonych zboczach. 
To takich zniekształceń możemy zaliczyć efekt skrócenia, cieni czy inwersji danych. Ponadto, przez to, 
że radary rejestrują dane pod pewnym kątem, w przypadku terenów górzystych, zbocze, które znajduje 
się od strony padania wiązki radarowej odbija sygnał znacznie silniej. Powoduje to dysproporcją 
w jasności pikseli na terenach o tym samym zagospodarowaniu powierzchni. W celu zminimalizowania 
negatywnego wpływu wspomnianych zniekształceń konieczne jest wykonanie korekcji z użyciem 
numerycznego modelu ternu (NMT) nazywanej spłaszczeniem terenu. 
 
W celu wykonania korekcji i zmniejszenia zniekształceń widocznych na obrazie SAR wybierz Radar > 
Radiometric > Radiometric Terrain Flattening. W I/O Parameters jako Source Product wybierz plik 
po filtracji z końcówką _Spk. W zakładce Processing Parameters wybierz warstwy Beta0 dla obu 
polaryzacji. Jako NMT, które posłuży do korekcji wybierz SRTM 1Sec HGT, który pobierze się 
automatycznie. Pozostałe opcje pozostaw odznaczone.  
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Nowy produkt zawiera warsztwy o nazwie Gamma0. Aby zobaczyć wpływ zastosowanego 
„spłaszczenia” otwórz warwstę Beta0_VV dla produktu po filtracji (_Spk) oraz Gamma0_VV dla 
produktu po spłaszczeniu (_TF). Zmianny będą szczególnie widoczne w obszarach o nachylonym 
terenie, tak jak na załączonym przykładzie. 

 

7. Analiza tekstury zobrazowania 

Na podstawie rozkładu współczynnik wstecznego rozpraszania i za pomocą statystyk lokalnych, 
możliwe jest utworzenie pliku opisującego teksturę analizowanego zobrazowania. Wartością 
szczególnie istotną jest rozproszenie plamkowe, którego wysokie wartości pozwala na detekcję 
obszarów zabudowanych i ich wyszczególnienie na obrazie. 
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W celu wykrycia obszarów zabudowanych należy wyliczyć tzw. speckle divergence czyli rozproszenie 
plamkowe, które wartości pozwolą na określenie położenia zabudowy. Z menu wybierz Radar > SAR 
Application > Urban Areas > Speckle Divergence. Jako plik wejściowy wybierz produkt z końcówkę 
_TF. W Processsing Parameters jako Source Bands wybierz warstwy Gamma0 dla obu polaryzacji. 
W linii Window Size możemy określić jak duże obszary będę przeszukiwane, aby określić wartość 
rozproszenia (speckle divergnece). Wielkość okna wpływa na dokładność detekcji obszarów 
zabudowanych w zależności od rozdzielczości przestrzennej obrazu, a więc należy ją testować za 
każdym razem. Początkowo ustaw wartość Window Size: 3x3. 

 
 

Poniżej przedstawiono obraz Gamma0_VV oraz speckle divergence dla watswy Gamma0_VV: 
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W zależności od rozdzielczości zobrazowań wygenerowany plik zawiera zakres obszarów 
zabudowanych wyświetlony w kolorze białym. W przypadku dużych rozmiarów piksela terenowego, 
otrzymany plik zawiera wyłącznie kontury większych obszarów zabudowanych, natomiast dla zdjęć 
o wyższej rozdzielczości możliwa jest detekcja nawet pojedynczych budynków. Otrzymane obrazy 
różnią się w zależności od polaryzacji, dlatego konieczne jest przeanalizowanie wszystkich obrazów 
w celu otrzymania optymalnego wyniku. 
 
8. Nadanie georeferecji 

W celu konwersji obrazów z układu radarowego do układu współrzędnych należy wybrać Radar > 
Geometric > Terrain Correction > Range-Doppler Terrain-Correction. 

W zakładce parametrów wskaż obraz Gamma0_VV_speckle_divergence. W polu numerycznego 
modelu terenu Digital Elevation Model wskaż: SRTM 1Sec HGT (Auto Download). Jako metodę 
przepróbkowania DEM DEM resampling method wybierz: Bicubic Interpolation, a jak w przypadku 
metody przepróbkowania obrazów transformowanych Image Resampling Method: 
BISNIC_5_POINT_INTEPROLATION. W zakładce Map Projection można zdefiniować układ 
współrzędnych, do którego chcemy przetransformować rastry. Domyślnie jest to układ WGS84. 
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9. Eksport do programu QGIS i wizualizacja wyniku 

Ostateczny plik z wykrytymi krawędziami wyeksportuj do formatu GeoTIFF, aby wyświetlić go 
w programie QGIS. W okienku Product Explorer zaznacz produkt po korekcji geometrycznej, 
a następnie wybierz File > Export > GeoTIFF / Big Tiff. W oknie eksportu można wybrać Subset, aby 
wyeksportować konkretną warstwę, natomiast w tym przypadku mamy do dyspozycji tylko jedną, 
dlatego klikamy Export Product. 

 
W następnym kroku należy przejść do programu QGIS i do nowego projektu przeciągnąć 
wygenerowany GeoTIFF.  

W panelu Warstwy przejdź do Właściwości warstwy i w zakładce Styl ustaw parametry jak niżej: 
• Sposób wyświetlania: Jednokanałowy pseudokolor, 
• Interpolacje: dyskretna, 
• Tryb: równe przedziały, 
• Liczba klas: 2 (oraz ustaw wartość graniczną pierwszej klasy na -0,16 i jej krycie na 0%, klikając 

PPM w ikonę koloru i zmień krycie. 
Następnie przejdź do zakładki przeźroczystość i jako Dodatkowe kodowanie braku danych wpisz 0 
i zatwierdź zmiany. 
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Do wyświetlonych wyników można dołączyć zobrazowanie optyczne Sentinel-2, które pomoże ocenić 
wizualnie wynik detekcji budynków. 

Do okna programu przeciągnij plik S2_20220320.tif, a następnie przejdź do właściwości warstwy 
i ustaw kompozycję w barwach rzeczywistych RGB (kanały w kolejności 321). 

 

 

W przypadku danych Setinel-1 niemożliwa jest detekcja pojedynczych budynków, lecz większych 
obszarów zurbanizowanych, takich jak całe dzielnice. Aby uzyskać lepszą dokładność należy 
wykorzystać zobrazowania SAR z wyższą rozdzielczością przestrzenną.  
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Opis ćwiczenia – cz.2 detekcja obszarów zabudowanych na obrazie Capella 

10. Wczytanie zobrazowań satelitarnych do programu SNAP 

W celu dodania zobrazowania do programu SNAP wybierz opcję File > Import > SAR Sensors > 
Capella, a następnie wskaż plik w formacie *_extended.json, znajdujący się w folderze 
z zobrazowaniami satelitarnymi 

 
Wczytane zobrazowanie pojawia się w oknie Product Explorer. 

Zaimportowane dane to produkt GEO pochodzący z jednego z satelitów konstelacji Capella. Po 
rozwinięciu danych produktu, rozwiń dodatkowo zakładkę Bands. Z uwagi na to, że produkty GEO są 
już wstępnie przetworzone i gotowe do analizy, to wśród danych produktu Capella znajduje się obraz 
współczynnika rozpraszania wstecznego Sigma0 dla wyłącznie jedne polaryzacji (HH). W celu 
wyświetlenia obrazu, należy dwukrotnie kliknąć na wybraną warstwę, natomiast z uwagi na wysoką 
rozdzielczość danych proces otwierania rastra trwa długo i zalecane jest wyświetlenie danych po 
przycięciu do obszaru zainteresowania. 
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Obraz Sigma0 dla całego zobrazowania: 

 
 

11. Ograniczenie zasięgu zobrazowań satelitarnych do obszaru opracowania 

Z uwagi na wysoką rozdzielczość zobrazowania i dużą objętość danych, w celu usprawnienia pracy, 
obszar opracowania zostanie ograniczony tylko do wybranego fragmentu Warszawy. 

W celu przycięcia zobrazowania wybierz opcję Raster > Subset. W oknie narzędzia Subset wybierz 
zakładkę Spatial Subset i zdefiniuj współrzędne prostokąta, który zostanie wykorzystany do 
ograniczenia zasięgu zobrazowania przechodząc do zakładki Geo Coordinates: 

Nort latitude bound:  52.246 
West longitude bound: 21.012 
South latitude bound: 52.224 
East longitude bound: 21.055 

 
W kolejnych zakładkach: Band Subset, Tie-Point Grid Subset oraz Metadata Subset pozostaw 
zaznaczoną opcję Select All.  
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Po kliknięciu OK w oknie Product Explorer zostanie utworzony nowy plik o nazwie subset_X_of_Y, 
gdzie X to numer podzbioru, Y to nazwa danych, z których pochodzi podzbiór. Dane przechowywane 
są w pamięci podręcznej i należy je zapisać na dysk lokalny do folderu ćwiczeniowego 
(MD_3_5\Wyniki). Produkty zapisuje się klikając prawym przyciskiem na nazwę nowostworzonego 
produktu (subset_X_of_XXXXXXX) i wybierając polecenie Save Product As.  

Po zapisaniu plików zaleca się zamknięcie wszystkich produktów w programie, a następnie otworzenie 
ponownie ostatnio zapisanych plików.  

Produkty zamyka się wybierając w głównym pasku narzędzi File > Close All Products bądź klikając 
prawym przyciskiem myszy w Product Explorer na dowolny produkt i wybierając opcję Close All 
Products. 

 
 

mailto:michal.pilecki@polsa.gov.pl


                                                                                               

21 

Siedziba główna Agencji |ul. Trzy Lipy 3 (Budynek C), 80-172 Gdańsk | tel. +48 58 500 87 60 | e-mail: sekretariat@polsa.gov.pl 
Oddział w Warszawie | ul. Prosta 70, 00-838 Warszawa | tel. +48 22 380 15 50 | e-mail: sekretariat.warszawa@polsa.gov.pl 
Oddział w Rzeszowie | ul. Warszawska 18, 35-205 Rzeszów | tel. +48 516 222 695 | e-mail: michal.pilecki@polsa.gov.pl 
 

 
 

Obraz Sigma0 dla ograniczonego obszaru: 

 
 
12. Filtracja efektu plamkowania 

Obrazowanie radarowe charakteryzuje się dużą zmiennością wartości sąsiadujących pikseli. Jest to tak 
zwany efekt plamkowania (ang. speckle effect), potocznie nazywany również efektem soli i pieprzu. 
W celu zredukowania efektu plamkowania wykonuje się filtrację obrazów. Filtracje mogą opierać się 
na różnych rozkładach np. normalnym (Gaussa) lub gamma. Wśród prostych metod filtracji wyróżnia 
się filtry oparte na średniej arytmetycznej (Boxcar) i medianie (Median). Do bardziej złożonych metod 
stosowanych do danych radarowych zalicza się metody takie jak Lee, Frost, IDAN, Gamma-MAP. 
Niestety nie istnieje idealny filtr, który spowodowałby wygładzenie obszarów homogenicznych przy 
zachowaniu pełnej szczegółowości i rozdzielczości. Wybór metody filtracji zależy całkowicie od 
użytkownika. Na potrzeby niniejszego zadania została wybrana metoda filtracji Lee Sigma. Filtr ten jest 
oparty na modelu rozkładu Gaussa i uśrednia tylko piksele w określonym zakresie odchyleń 
standardowych.  

W głównym pasku narzędzi wybierz Radar > Speckle Filtering > Single Product Speckle Filter. 
W zakładce I/O Parameters w polu Source Product wskaż dane po kalibracji radiometrycznej. 
W zakładce Processing Parameters w polu Source Band wskaż warstwę Sigma0_HH i wybierz 
metodę filtracji Filter: Lee Sigma, Windows size: 5x5, Target Window Size: 3x3 a pozostałe 
parametry pozostaw domyślne. Po ustawieniu parametrów kliknij Run. 
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Fragment analizowanego zobrazowania przed (po lewe) i po zastosowaniu filtracji (po prawej). 
Widoczne jest zredukowanie szumów na obrazie kosztem rozdzielczości. 

 

13. Analiza tekstury zobrazowania 

Na podstawie rozkładu współczynnika wstecznego rozpraszania i za pomocą statystyk lokalnych, 
możliwe jest utworzenie pliku opisującego teksturę analizowanego zobrazowania. Wartością 
szczególnie istotną jest rozproszenie plamkowe, którego wysokie wartości pozwalają na detekcję 
obszarów zabudowanych i ich wyszczególnienie na obrazie. 
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W celu wykrycia obszarów zabudowanych należy wyliczyć tzw. speckle divergence czyli rozproszenie 
plamkowe, którego wartości pozwolą na określenie położenia zabudowy. Z menu wybierz Radar > 
SAR Application > Urban Areas > Speckle Divergence. Jako plik wejściowy wybierz produkt 
z końcówkę _Spk. W Processsing Parameters jako Source Bands wybierz warstwę Sigma0. W linii 
Window Size możemy określić jak duże obszary będę przeszukiwane, aby określić wartość 
rozproszenia (speckle divergnece). Wielkość okna wpływa na dokładność detekcji obszarów 
zabudowanych i należy ją testować za każdym razem. Początkowo ustaw wartość Window Size: 
15x15. Przetestuj inne wielkości okna, aby zobaczyć różnicę. 
 

 
 
Poniżej przedstawiono kolejno obraz Sigma0, speckle divergence dla tej samej warstwy oraz maskę 
z wykrytymi krawędziami obszarów zurbanizowanych: 

Sigma0  
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Speckle divergence 

 
Maska: 

 
 
Otrzymane grafiki prezentują w kolorze białym krawędzie zabudowy, która możliwa była do wykrycia 
na podstawie statystyk wyliczonych ze współczynnika rozpraszania wstecznego. Wygenerowane pliki 
mogę posłużyć do określenia granic terenów zurbanizowanych. W przypadku kilku zobrazowań, 
podobna analiza pomoże we wskazaniu rejonów miasta, dla których zabudowa uległa zmianie. 
Pozwala to na detekcję nowopowstałych osiedli czy większych obiektów miejskich. 
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14. Eksport danych do systemów GIS wraz z wizualizacją 

Ostateczny plik z wykrytymi krawędziami wyeksportuj do formatu GeoTIFF, aby wyświetlić go 
w programie QGIS. Wybierz File > Export > GeoTIFF / Big Tiff. W oknie eksportu można wybrać Subset, 
aby wyeksportować konkretną warstwę, natomiast w tym przypadku pozostawiamy do eksportu obie 
warstwy: Sigma0_HH oraz Signa0_HH_speckle_divergence.  

 
W następnym kroku należy przejść do programu QGIS i do nowego projektu przeciągnąć 
wygenerowany GeoTIFF.  

W panelu Warstwy przejdź do Właściwości warstwy i w zakładce Styl ustaw parametry jak niżej: 
• Sposób wyświetlania: kolor wielokanałowy, 
• czerwony (R): Kanał 1 (Grey), 
• zielony (G): Kanał 2. 

 
Do wyświetlonych wyników można podłączyć podkłady mapowe przez menu Warstwa > Dodaj 
warstwę > Dodaj warstwę XYZ. Aby porównać wykryte krawędzie zabudowy z rzeczywistym 
zagospodarowaniem terenu można podłączyć mapę OpenStreet Map poprzez wybranie z listy 
Połączenia XYZ: OpenStreetMap lub jeżeli to połączenie nie jest dostępne, dodanie nowego 
połączenia (Nowy):                 

OSM, URL: https://tile.openstreetmap.org/{z}/{x}/{y}.png 
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Raster z wykrytą zabudową wyświetlony zostanie w kolorystyce czerwono-zielonej. Na czerwono 
zaznaczone są obszary nie będące zabudową, a na zielono krawędzie budynków, mostów czy dróg. 
Poprzez włączenie/wyłączenie GeoTIFFu można porównać wyniki z rzeczywistymi budynkami 
w terenie ukazanymi na pokładzie mapowym. 

 
Dokładność wyznaczenie krawędzi w dużej mierze zależy od rozdzielczości przestrzennej 
zastosowanych zobrazowań. W przypadku danych Setinel-1 niemożliwa będzie detekcja pojedynczych 
budynków, lecz większych obszarów zurbanizowanych, takich jak całe dzielnice. Dla prezentowanych 
danych z konstelacji Capella możliwe jest wykrycie krawędzi pojedynczych obiektów, natomiast 
widoczne są zniekształcenia geometryczne spowodowane sposobem rejestrowania danych np. 
budynki wychodzące poza swoją podstawę. Niemniej jednak przy zastosowaniu podobnej analizy dla 
szeregu obrazów SAR możliwe jest wykrycie różnic w zabudowie miejskiej: zarówno w dla nowo 
wybudowanych obiektów, jak i wyburzanych, bądź modyfikowanych fragmentów miasta. 
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